The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Transfer homedir no longer streaming in 11.30?

Discussion in 'General Discussion' started by Valetia, Jul 22, 2011.

  1. Valetia

    Valetia Well-Known Member

    Joined:
    Jun 20, 2002
    Messages:
    207
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    When copying accounts via WHM, homedir streaming used to work pre-11.30.

    Now it just packages everything up and then send them over in fixed .tar.gz.parts, like during the pre-streaming days.

    Any way to get the streaming feature back?

    Here's our specific backup configuration, which has remained the same through 11.28 and 11.30:

    - Backups: enabled
    - Incremental: enabled
    - Backup accounts: disabled (we perform those separately)
    - Backup config files: enabled
    - Backup SQL: per account
    - Backup type: standard
    - Hard links: disabled
    - Optimized tool: disabled
    - Destination: /backup
     
  2. davetanguay

    davetanguay Active Member

    Joined:
    Mar 30, 2008
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Having the same problem. Did you ever find a solution?
     
  3. Valetia

    Valetia Well-Known Member

    Joined:
    Jun 20, 2002
    Messages:
    207
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    It just started working again on its own, so we have no idea what the exact solution was. We did adjust quite a number of settings over a period of several weeks, and one or more of those could have resolved the issue.

    Please try the following:

    A) Firewalls:

    Make sure both machines have TCP 22 (or whatever SSH port you use) and 2087 IN/OUT unblocked.

    We have port 2086 blocked for security reasons.

    B) WHM Tweak Settings (Security Tab):

    Allow autocomplete - Off
    Cookie IP - Disabled
    Blank referrer - Off
    Referrer - Off
    Require SSL - Off
    Enable HTTP Authentication - On
    Security Tokens - Off

    (Note: The above are just our current security settings for our purposes, they may or may not affect the WHM account copy process, nor do we specifically recommend using those exact settings)

    C) Copy Accounts:

    Remote Server Address: (make sure to enter the complete FQDN, not just the front part if you're used to that. come to think of it, this could have been the cause of the problem. not 100% sure though)
    Don't Compress Transfers: Off
    Use SSL: On
    Use Incremental Backups speed-up: Off
    Allow Override: Off
    Login: Root
    Authentication Method: Password

    Hope this helps. :)
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    For the remote server address field when copying accounts, I suggest using the IP address. That doesn't require DNS resolution to work at all.
     
  5. davetanguay

    davetanguay Active Member

    Joined:
    Mar 30, 2008
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Thanks! I got it working. I think the problem for me was it will not work if I use:

    Authentication Method: Public Key

    I tried using Password instead and it works just fine! Thanks again!
     
Loading...

Share This Page