Transfer Tool & Automatically-Issued Hostnames

Operating System & Version
CloudLinux v7.9.0
cPanel & WHM Version
108.0.6

optx

Registered
Jan 24, 2023
2
0
1
smokapack
cPanel Access Level
Root Administrator
I am migrating my server and have

oldserver.apples.com (ns1.apples.com - ns2.apples.com) (an A record set on apples.com pointing to newserver.apples.com)
newserver.apples.com (ns1.apples.com - ns2.apples.com)

The A record pointing to newserver.apples.com was setup on oldserver to allow the setting up of reverse dns for newserver.

I have setup newserver.apples.com using ns1.apples.com - ns2.apples.com and it has been issued a cprapid.com service SSL certificate.

I now have a close matching setup on newserver.apples.com and am ready to use Transfer Tool to move all the cPanel accounts over.

ns1.apples.com & ns2.apples.com nameservers will have new IPs running on newserver.apples.com.

After I have transferred all of the cPanel accounts using Transfer Tool I will update the glue records for the two nameservers to the new IP addresses.

I have read here https://docs.cpanel.net/knowledge-base/dns/automatically-issued-hostnames/

Taking flight

We encourage users to replace the auto-issued hostname with an existing domain or purchase a new domain to generate a hostname. Using your own domain name and hostname will help establish your company’s brand.

To change the server’s hostname, use WHM’s Change Hostname interface (WHM » Home » Networking Setup » Change Hostname).

After a user changes the server’s auto-issued hostname to their new hostname, the Certificate Authority will issue a new certificate for the server and the change should be seamless.


My question are,

1) At what point do I ask for a new service SSL certificate on newserver.apples.com once the nameserver IPs have been changed to the new IPs? And how do I ask for that to happen when newserver.apples.com already has the server hostname setup? With a mailserver running it is essential that the service SSL is correct asap.

2) Once the glue records for ns1.apples.com & ns2.apples.com have been updated how do I update those records on newserver, does it just pickup the ip change automatically? Then I do Basic WebHost Manager® Setup > Nameservers > Configure Address Records > Configure Address Records button. Then run Perform a DNS Cleanup to set the new nameserver IP's on all the cPanel accounts.

3) Just on a side note, using Transfer Tool to do a test transfer for one cPanel account from olderver to newserver, newserver is now showing '[2/2] The timeout specified has expired' in apache status for all accounts, is this expected behaviour?
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
13,329
2,102
363
cPanel Access Level
Root Administrator
Hey there! There's no reason you couldn't fix issues 1 and 2 before you do the transfer. You can set the hostname to be the full FQDN you want in place on newserver, and then just create an A record so it points to the correct IP. This way, the hostname is in place before you perform the transfer.

Then, when you're ready, you can switch the ns1 and ns2 glue/A records over to the new machine, and the transition will be seamless. With this method, you never need to change from the cprapid hostname cert to the "real" domain name cert while the system is in production.

For the second part of issue 2, the NS records only contain the nameserver name, and not the IP address, so you wouldn't need to manually update all the domains.

For issue number 3, no, that doesn't sound normal. If you tested with Live Transfer (Transfer Tool | cPanel & WHM Documentation) all the traffic would be proxied over to the new machine. If you didn't, then I would expect the DNS to still point to the old system unless you also updated that as part of your testing. But neither option should lead to a timeout error. You might want to check and ensure that the firewall is properly configured on the source machine and that you can reach port 80 properly.
 

optx

Registered
Jan 24, 2023
2
0
1
smokapack
cPanel Access Level
Root Administrator
Thanks for this @cPRex everything worked out well and the transfer is now complete. I also figured out that point 3 was caused by my own php ini settings change of max_input_time - I guess all the excitement of the transfer had me acting a little crazy. Anyways thanks again for helping me get all my apples in one basket ;)