The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Transfer Tool Failure

Discussion in 'Data Protection' started by willinit, Oct 6, 2016.

Tags:
  1. willinit

    willinit Registered

    Joined:
    Nov 19, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    When attempting to migrate an account from a remote server, the transfer tool is giving the following error (IP.ad.dr.ess:Port is substituted for the real IP and port):

    I know that the key and everything is correct as I'm able to SSH into the remote server from the command line. Is the "ControlPersist" option it's mentioning something that can easily be disabled? Does the error mean the option is enabled on the remote server or the local server that's trying to pull in the account? Or is this due to something completely different?

    Thank in advance for any help you can provide.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    34,401
    Likes Received:
    1,005
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Is CentOS 5 installed on the source server? If so, you will need to temporarily disable the ControlPersist option in the destination server's /etc/ssh/sshd_config file, as CentOS 5 does not support this variable. You can do this by editing the file and setting the option to "No" or by commenting out the line. Ensure you restart the SSH service after making the change.

    Thank you.
     
  3. MrCoal

    MrCoal Member

    Joined:
    Dec 11, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I have this same problem but do not have a ControlPersist option in sshd_config. If I add the option, SSH will not retstart because of an invalid configuration.

    Openssh on the source is 4.3p2 and the destination is 5.3p1. I can manually SSH into the source server from the destination server.
     
  4. MrCoal

    MrCoal Member

    Joined:
    Dec 11, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I got this to work by adding the following in /etc/ssh/ssh_config

    ControlMaster no
    ControlPersist no
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,150
    Likes Received:
    262
    Trophy Points:
    83
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
Loading...

Share This Page