The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Transfer Tool giving me errors

Discussion in 'Data Protection' started by DigitalEssence, Apr 25, 2017.

Tags:
  1. DigitalEssence

    Joined:
    May 21, 2014
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hi,

    I'm trying to transfer a test site from Server A to server B and am getting some odd errors.

    90% of the time I get:

    Code:
    There is no SSH server listening on “IP_ADDRESS:22”: Unknown error; No error sent.
    I sometimes get this error:

    Code:
    The remote basic credential check failed due to an error (The password that you provided is not correct, or the SSH key is not permitted access: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).) and response: Connecting to IP_ADDRESS:22 as USER_NAME...using method password...Connecting to IP_ADDRESS:22 as USER_NAME...using method password...
    And very rarely I get:


    Code:
    The system failed to fetch information about the remote server in preflight phase 0, and returned the error: Failed to execute “(echo -n "==ssh_multi_exec=begin=1=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/scripts/analyze_config --version 2>/dev/null;echo -n "==ssh_multi_exec=end=1=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=2=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/scripts/unpkgacct --version 2>/dev/null;echo -n "==ssh_multi_exec=end=2=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=3=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/scripts/dump_databases_and_users --version 2>/dev/null;echo -n "==ssh_multi_exec=end=3=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=4=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/scripts/pkgacct-wrapper --version 2>/dev/null;echo -n "==ssh_multi_exec=end=4=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=5=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/scripts/xferpoint --version 2>/dev/null;echo -n "==ssh_multi_exec=end=5=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=6=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /bin/cat /usr/local/cpanel/version 2>/dev/null;echo -n "==ssh_multi_exec=end=6=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=7=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/bin/pkgacct --get_version 2>/dev/null;echo -n "==ssh_multi_exec=end=7=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=8=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C [ -d '/var/cpanel/packages/extensions' ] && echo 1 '' 2>/dev/null;echo -n "==ssh_multi_exec=end=8=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=9=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C [ -e '/usr/local/frontpage/version5.0/bin/owsadm.exe' ] && echo 1 '' 2>/dev/null;echo -n "==ssh_multi_exec=end=9=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=10=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C [ ! -e '/usr/local/cpanel/scripts' ] && mkdir -p /usr/local/cpanel/scripts '' 2>/dev/null;echo -n "==ssh_multi_exec=end=10=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=11=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C [ ! -e '/usr/local/cpanel/scripts/Cpanel' ] && mkdir -p /usr/local/cpanel/scripts/Cpanel '' 2>/dev/null;echo -n "==ssh_multi_exec=end=11=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=12=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /bin/grep HOMEDIR /etc/wwwacct.conf 2>/dev/null;echo -n "==ssh_multi_exec=end=12=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=13=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/bin/cpconftool --query-module-info --modules=cpanel::easy::apache 2>/dev/null;echo -n "==ssh_multi_exec=end=13=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=14=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/bin/cpconftool --query-module-info --modules=cpanel::system::backups 2>/dev/null;echo -n "==ssh_multi_exec=end=14=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=15=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/bin/cpconftool --query-module-info --modules=cpanel::smtp::exim 2>/dev/null;echo -n "==ssh_multi_exec=end=15=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=16=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/bin/cpconftool --query-module-info --modules=cpanel::system::mysql 2>/dev/null;echo -n "==ssh_multi_exec=end=16=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=17=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/bin/cpconftool --query-module-info --modules=cpanel::ui::themes 2>/dev/null;echo -n "==ssh_multi_exec=end=17=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==");(echo -n "==ssh_multi_exec=begin=18=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==";LC_ALL=C /usr/local/cpanel/bin/cpconftool --query-module-info --modules=cpanel::system::whmconf 2>/dev/null;echo -n "==ssh_multi_exec=end=18=";echo -n "Whostmgr::Remote::fVj1H7Dn";echo -n "Whostmgr::Remote::BgYsa5tQ==")” on remote host “IP_ADDRESS” …
    
    can ssh from server B to A on the command line although sometimes I get an error. It certainly isn't anywhere near 90% of the time, perhaps 5%. The IP address of server B has been allowed through the firewall of A.

    Code:
    ssh_exchange_identification: Connection closed by remote host
    If I run ssh with debug I get the following:

    Code:
    ssh USER_NAME@IP_ADDRESS -vv
    OpenSSH_6.6.1, OpenSSL 1.0.1e-fips 11 Feb 2013
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 56: Applying options for *
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to IP_ADDRESS [IP_ADDRESS] port 22.
    debug1: Connection established.
    debug1: permanently_set_uid: 0/0
    debug1: identity file /root/.ssh/id_rsa type -1
    debug1: identity file /root/.ssh/id_rsa-cert type -1
    debug1: identity file /root/.ssh/id_dsa type -1
    debug1: identity file /root/.ssh/id_dsa-cert type -1
    debug1: identity file /root/.ssh/id_ecdsa type -1
    debug1: identity file /root/.ssh/id_ecdsa-cert type -1
    debug1: identity file /root/.ssh/id_ed25519 type -1
    debug1: identity file /root/.ssh/id_ed25519-cert type -1
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_6.6.1
    ssh_exchange_identification: Connection closed by remote host
     
    #1 DigitalEssence, Apr 25, 2017
    Last edited by a moderator: Apr 26, 2017
  2. DigitalEssence

    Joined:
    May 21, 2014
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Update.

    Just tried again. About 5 of these errors:

    Code:
    There is no SSH server listening on “IP_ADDRESS:22”: Unknown error; No error sent.
    then this:

    Code:
    The remote basic credential check failed due to an error (The remote server “IP_ADDRESS” unexpectedly terminated the connection. The port may be incorrect, or the remote server may not allow connections from this server: Connection closed) and response: Connecting to IP_ADDRESS:22 as USER_NAME...using method password...Connection Success
    
    Waiting for login prompt ....Done waiting for login prompt.
    Normalizing user level shell...
    Done normalizing shell.
    Attempting to obtain root using method "su w/root pass"
    Sending password for su w/root pass...
    su w/root pass success...
    ==sshcontrolescalation_method=su w/root pass==
    Normalizing root shell....
    Done normalizing shell.
    zz c_52918928_P c_20847930P zz
    c_59718356_P:c_82452919P:cPs#c_59718356_P:c_82452919P:cPs#c_60121810_P__==sshcontroloutput==Cpanel::SSHControl::joerWyJgeLhFNoJb==
    ==sshcontroloutput==Cpanel::SSHControl::joerWyJgeLhFNoJb==
    __c_76445122P___c_71340110_P__c_40719124P___c_59718356_P:c_82452919P:cPs#c_59718356_P:c_82452919P:cPs#c_59718356_P:c_82452919P:cPs#c_59718356_P:c_82452919P:cPs#exit
    exit
    
    ==sshcontrolpid=8249==
    
    ==sshcontrolpath=/root/.libnet-openssh-perl/USER_NAME-146.18-8249-617053==
     
    #2 DigitalEssence, Apr 25, 2017
    Last edited by a moderator: Apr 26, 2017
  3. DigitalEssence

    Joined:
    May 21, 2014
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    I've got it working. But it's a workaround.

    My source server was set to not allow root logins via ssh. I have now enabled these and ran the transfer tool again and it has worked.

    FYI: To enable/disable root logins via ssh:

    edit: /etc/ssh/ssh_config
    Add: PermitRootLogin yes
    save and exit
    service sshd restart

    I don't think I should have to do this if the Transfer Tool has the settings to allow su from another user but at least I have it working.
     
  4. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,404
    Likes Received:
    52
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    Switching the user virtually is difficult for a script to elevate the user through it. If you are transferring full server, root access is mandatory and that it should be accessible through SSH, as transfer tool does most of the rsync type job at the end to transfer the data of home directory.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
  6. DigitalEssence

    Joined:
    May 21, 2014
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hi, the source server uses 6.9.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature if you'd like us to take a closer look. You can post the ticket number here and we will update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page