Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Transfer Tool Issues - Random port numbers

Discussion in 'Data Protection' started by FourMat, Nov 2, 2017.

Tags:
  1. FourMat

    FourMat Active Member

    Joined:
    Jun 10, 2004
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    156
    There was another thread with this but the OP didn't follow up with answers to the questions, therefore there was no resolution.

    I'm running into an error with the Transfer Tool

    Local Server - Centos 6.5, WHM 66.029
    Remote server - Centos 7.4, WHM 66.029 - SSH listening on port 22

    When I try to connect local server to remote server through the Transfer Tool using port 22, escalating from user to root using su (no keys) I receive the following:

    The remote basic credential check failed due to an error (The password that you provided is not correct, or the SSH key is not permitted access: command-line: line 0: Bad configuration option: ControlPersist) and response: Connecting to XXX.XXX.XXX.68:22 as admin...using method password...Connecting to XXX.XXX.XXX.68:22 as admin...using method password...

    I can confirm that I can SSH from the local server to the remote server just fine. When I look at the /var/logs/secure log for the local servers IP address, I see these messages:

    Nov 2 08:21:38 remoteserver sshd[51466]: Did not receive identification string from XX.XXX.XX.97 port 48302
    Nov 2 08:22:57 remoteserver sshd[51612]: Did not receive identification string from XX.XXX.XX.97 port 48307

    Every time I try to connect, the error message that is returned has a different port number, not port 22. What is causing this? I have confirmed that I have the local server whitelisted in both CSF+LFD and cPHulk.

    I have to assume that the firewall IS blocking attempts from those random port numbers. Which is causing the error.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,943
    Likes Received:
    1,820
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You can temporarily disable the ControlPersist option in the destination server's /etc/ssh/sshd_config file. Ensure you restart the SSH service after making the change, and let us know if that helps.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. FourMat

    FourMat Active Member

    Joined:
    Jun 10, 2004
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    156
    When you say the "destination server" do you mean the local server (recipient of the transferred account) or the remote server (the source of the account) as I have outlined in the description above?

    When I add:

    ControlPersist no

    /etc/ssh/sshd_config the restart service process fails. If I add it to /etc/ssh/ssh_config there is no change. Is this the proper syntax? I'm assuming it's ok to add it most anywhere in the file, so I appended the option to the end.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,943
    Likes Received:
    1,820
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hi,

    I'm referring to the local server (the one you are accessing "WHM >> Transfer Tool" on). Could you open a support ticket using the link in my signature so we can take a closer look?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice