The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Transferred accounts all redirecting to default website page

Discussion in 'Bind / DNS / Nameserver Issues' started by mike817, Nov 10, 2015.

  1. mike817

    mike817 Member

    Joined:
    Aug 5, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I just reformatted my server and reinstalled cpanel. Then i transferred all my sites back, but they're all redirecting to the default website page. I checked the paths and the ip settings and they both look correct. Can anyone suggest anything else I need to checkout?
     
  2. mike817

    mike817 Member

    Joined:
    Aug 5, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Also direct pages can be accessed fine. But if you hit the top level domain you get redirected. Completely lost here.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can rebuild the Apache configuration file via:

    Code:
    /scripts/rebuildhttpdconf
    Try clearing the browser and DNS cache on your computer and then checking to see if the websites load.

    Thank you.
     
  4. mike817

    mike817 Member

    Joined:
    Aug 5, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I've rebuilt the httpd.conf a few times now and manually checked the file and I'm not seeing anything wrong. I've cleared the cache multiple times as well but no luck. The weirdest part is it only happens on the top level. If you specify a file directly it loads fine.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  6. mike817

    mike817 Member

    Joined:
    Aug 5, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Yes, DNS is setup correctly. Mail is working, directly linked files are working. But when you hit the domain it redirects to the default webpage.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Are there any rules within the .htaccess file in the account's home or public_html directory that could be redirecting the domain name?

    Thank you.
     
  8. mike817

    mike817 Member

    Joined:
    Aug 5, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    None that I see. I'm going to try backing up the sites and then deleting and recreating.
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page