The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Transferred pkgs have dedicated IP

Discussion in 'General Discussion' started by dory36, Dec 24, 2006.

  1. dory36

    dory36 Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    I set up a new server by transferring a number of accounts and packages from another server.

    For some reason, all the packages came over with the Dedicated IP address option set to true, unlike the originals. When I try to edit the packages, that option is not editable -- it just shows the "yes".

    Is there a way to change that option on the new server, other than deleting and recreating all the packages?

    Thanks - Bill
     
  2. embsupafly

    embsupafly Active Member

    Joined:
    Dec 24, 2003
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    This has also happened to me. I need this fixed and have not found anything yet. Most people are telling me that I have to delete the package and recreate it but there must be a way to fix this. It shows up as dedicated ip = yes in the package editor inside WHM, but if you are in the package filename in /var/cpanel/packages, dedicated ip is set to no. So I am not sure what is wrong here, is there a script to fix this. Can someone help?
     
  3. spiralfive

    spiralfive Member

    Joined:
    Jan 23, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I'm having this problem also and need it fixed ASAP. How do you remove the dedcated IP from all of the packages (as it was added to them when transferred to my new server)?
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    There's a weird bug with transferring packages. We know the end result (which you are describing) but are still trying to nail down the particulars.

    The short for this thread: to resolve the issue, redo the line endings for each package file afflicted.

    For example, with the package named "Test":

    1. SSH into the server with the problem package, as root
    2. cd /var/cpanel/packages
    3. Open the file "test" in your favorite text editor (jed, vim, nano, pico, etc)
    4. Replace each line ending with a "true" new line:
    4a. for each line in the file, goto the end of the line
    4b. hit the delete key to delete the line ending (this should cuase the next line to come o the line you are currently on)
    4c. with your cursor on the first line of the line appended by the last step, hit the enter key
    5. Save the file and close your text editor
    6. Problem solved

    If you open the file in vi or vim, you can enable viewwing of invisilbe characters :)set list) and then do a search/replace
     
  5. spiralfive

    spiralfive Member

    Joined:
    Jan 23, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    That didn't fix it. I edited one plan, multiple times, but it still says that it has a dedicated IP address. I'll try re-transffering the accounts later. If it doesn't work, I'll open a support ticket.
     
  6. dory36

    dory36 Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    It also works to just type "dos2unix pkgname" to fix the problem with package pkgname...
     
  7. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Oh sure, go ahead and make it easy.... ;)
     
  8. DannyM

    DannyM Member

    Joined:
    Jul 31, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here, fixed with: dos2unix *
     
Loading...

Share This Page