robhooper

Member
Jul 21, 2015
12
1
53
Farnborough
cPanel Access Level
Root Administrator
Hi,
Over the last few days I have received multiple errors regarding sites failing to transfer to s3.
I cannot see anything in the backup log and am looking at the transport logs.

However the transport logs do not go back far enough. Can I increase the amount of logs it stores?

Thanks.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello :)

It's not possible to change the retention period for the transport logs, but could you let us know the error messages you have received? Also, you could force a backup generation if you need to see updated log entries. EX:

Code:
/usr/local/cpanel/bin/backup --force
Thank you.
 

robhooper

Member
Jul 21, 2015
12
1
53
Farnborough
cPanel Access Level
Root Administrator
Hello,

Thanks for getting back to me.

Following is the error message I recieved:
Unable to send “/home/backup/2015-07-20/accounts/redacted.tar.gz” to destination “Amazon S3”

I am reluctant to force a backup because there is a large number of sites it would backup and it would take several hours.
As well as this the error doesn't seem to happen every time. I was just hoping to increase how many logs are stored to be prepared for next time.

It looks like the transport log is rotated each time the transport agent runs, would it be possible for it to just use the same log each time and stop rotating?

This looks like something to improve upon on your end ;)

Thanks,
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
It looks like the transport log is rotated each time the transport agent runs, would it be possible for it to just use the same log each time and stop rotating?
Please ensure you open feature requests via:

Submit A Feature Request

This ensures other users can vote or add feedback to the request, and our developers can review the request and update the status as necessary.

Thank you.
 

robhooper

Member
Jul 21, 2015
12
1
53
Farnborough
cPanel Access Level
Root Administrator
Please ensure you open feature requests via:

Submit A Feature Request

This ensures other users can vote or add feedback to the request, and our developers can review the request and update the status as necessary.

Thank you.
I have visited the feature request link you provided but it isn't working.
When I go to the feature request site (https://features.cpanel.net/) I am not logged in and if I try and log in with my forum details it doesn’t work.
If I try to reset my password it says that my account doesn't exist!
 

Infopro

Well-Known Member
May 20, 2003
17,090
516
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
There's an issue right now with the single sign on option for the Feature Requests site. If you've been logged into the Feature Requests site before, please send me a PM with the email address you were using at the time. I've just checked your current email and cannot find it in the Feature Requests system.

If you've never logged into the Feature Request site before, please register an account using the same details as your forum account (username, email address), your password will be different.

We're hoping to get this sorted out soon, in the meantime, that'll get you in ok. ;)

HTH!