The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tricky domain configuration questions

Discussion in 'General Discussion' started by jer2eydevil88, Jul 2, 2007.

  1. jer2eydevil88

    jer2eydevil88 Member

    Joined:
    Mar 14, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I have two sites
    example.com
    example.net

    example.com is hosted on a shared windows server
    example.net is hosted on a dedicated Linux Cpanel/WHM server

    I want to point
    subdomain.example.com to a forum software located at example.net/subdomain

    so far I have setup an A name entry in my DNS control panel for subdomain.example.com to be pointed at the IP address that I host example.net off of.

    And I added the following to httpd.conf on the Cpanel/WHM server.
    Code:
    <VirtualHost *:80>
    DocumentRoot /home/example/public_html/board
    ServerAdmin [email]webmaster@example.com[/email]
    ServerAlias subdomain.example.com
    ServerName subdomain.example.com
    </VirtualHost>
    I restarted Apache and still subdomain.example.com is displaying
    instead of the directory I pointed it to.


    Can anyonehelp me get this setup right?

    I host both sites and manage all domains at Godaddy.com which has great pricing and the worst support I have ever had. They sell Cpanel but can't actually answer any questions I have.
     
  2. jer2eydevil88

    jer2eydevil88 Member

    Joined:
    Mar 14, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Its Fixed

    Okay I figured it out.

    I created a new account for subdomain.example.com inside of Cpanel, I then went and modified httpd.conf where the path for that user was and made it the path to the forum software of the other user.

    Hope this helps someone else.
     
Loading...

Share This Page