The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tried autofix=safesshrestart but still no SSH

Discussion in 'General Discussion' started by shananiganzzz, Nov 11, 2010.

  1. shananiganzzz

    shananiganzzz Registered

    Joined:
    Nov 11, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    We had SSH access just fine until an automatic WHM update (or maybe from my vps host)

    Tried tried the http://ip:2086/scripts2/doautofixer?autofix=safesshrestart but no luck...all I get is

    AutoFixer Execution
    Requesting script ... Done. Executing script ...


    And that's it. Apparently the autofixer is not working.

    Does anyone have any suggestions of how to get back my SSH Access?? As I said, we did not make any changes. It simply worked one day and not the next.
     
  2. InterServed

    InterServed Well-Known Member

    Joined:
    Jul 10, 2007
    Messages:
    255
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    DataCenter Provider
    You might try a graceful server reboot from WHM.
     
  3. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    If the autofixer does not work, then either remote console or direct physical access will be required. The autofixer attempts to replace the sshd configuration with a very basic sshd_config, and if it does not work, there is another problem affecting sshd, or possibly even a firewall blocking access.

    If this has not been resolved, the best thing to do will be to contact your data center and ask them to investigate the sshd problem from the console.
     
  4. acenetryan

    acenetryan Well-Known Member
    PartnerNOC

    Joined:
    Aug 21, 2005
    Messages:
    197
    Likes Received:
    1
    Trophy Points:
    18
    Were there any entries in the cPanel error log when using autofixer to restart SSH? I recently tried this as well and got the error:

    Unknown open() mode '|' at whostmgr/bin/whostmgr2 line 3552.
     

Share This Page