Senioryoshi83

Registered
Aug 28, 2017
2
1
3
Chile
cPanel Access Level
Root Administrator
Hi, i'm trying to update libxml2 because I need the php extension DOMDocument 2.7.8 or higher.

I tried to do this by using

yum update libxml2

but it says that the package libxml2-2.7.6-21.el6_8.1.x86_64 it's already the last version available (and installed)

I used

cat /etc/redhat-release

Output: CENTOS 6.9

rpm -qa|grep libxml2

Output:
libxml2-2.7.6-21.el6_8.1.x86_64
libxml2-python-2.7.6-21.el6_8.1.x86_64
libxml2-devel-2.7.6-21.el6_8.1.x86_64

How can I update this?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hello,

EasyApache 4 will use OS provided libraries for libxml2. Thus, if you wanted to use version newer than what your OS provides, then you'd need to manually install that version of libxml2 in your OS. You may want to post to the CentOS forums for help with that:

CentOS - CentOS 6

Thank you.