The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trouble authenticating with cURL

Discussion in 'General Discussion' started by Deputy963, Aug 3, 2015.

  1. Deputy963

    Deputy963 Registered

    Joined:
    Aug 3, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    US
    cPanel Access Level:
    Root Administrator
    I'm at my wits end here, folks!

    I'm a newbie and having some difficulty authenticating to Twitter, LinkedIn, and Pinterest with cURL. Google and Facebook work perfectly.

    The best I can come up with is the intermediate certificate is outdated, but my attempts to rectify that by updating the cert in /etc/pki/ca-trust/source/anchors/ have been less that productive.

    WHM 11.50.00 (build 29)
    CentOS 6.6
    LiteSpeed 5.0.3
     
  2. Deputy963

    Deputy963 Registered

    Joined:
    Aug 3, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    US
    cPanel Access Level:
    Root Administrator
    Does anyone have any ideas as to what I'm overlooking, or what is wrong? google.com and facebook.com authenticate over SSL as they are supposed to. pinterest.com twitter.com and linkedin.com do not.
     
    #2 Deputy963, Aug 4, 2015
    Last edited by a moderator: Aug 5, 2015
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  4. Deputy963

    Deputy963 Registered

    Joined:
    Aug 3, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    US
    cPanel Access Level:
    Root Administrator
    It appears 11.50.1(b1) fixed the issue.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I'm happy to see the issue is no longer occurring. Thank you for updating us with the outcome. Note I can't determine a particular case that would have addressed the issue without further investigation, but for reference the change log is available at:

    11.50 Change Log

    Thank you.
     
Loading...

Share This Page