The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trouble doing Cpanel Updates

Discussion in 'General Discussion' started by Avg-Joe, Sep 16, 2006.

  1. Avg-Joe

    Avg-Joe Member

    Joined:
    Mar 28, 2002
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I'm getting the following problem while doing regular cpanel updates.

    Code:
    => SMTP Mail protection has been enabled.  Only users with the gid mail or mailman may make smtp connections.
    (internal death) Sat Sep 16 23:40:45 2006 [15797] error: List::Util object version 1.09_00 does not match bootstrap parameter 1.18 at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/XSLoader.pm line 106.
            XSLoader::load('List::Util',1.18) called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 25
            eval {...} called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 27
            eval {...} called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 19
            require List/Util.pm called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/Scalar/Util.pm line 12
            require Scalar/Util.pm called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBI.pm line 281
            eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBI.pm line 280
            require DBI.pm called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBD/mysql.pm line 7
            DBD::mysql::BEGIN() called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 0
            eval {...} called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 0
            require DBD/mysql.pm called at /usr/local/cpanel/cpanellogd line 62
            main::BEGIN() called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 0
            eval {...} called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 0
    (internal death) Sat Sep 16 23:40:45 2006 [15797] error: List::Util object version 1.09_00 does not match bootstrap parameter 1.18 at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 30.
            eval {...} called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 19
            require List/Util.pm called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/Scalar/Util.pm line 12
            require Scalar/Util.pm called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBI.pm line 281
            eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBI.pm line 280
            require DBI.pm called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBD/mysql.pm line 7
            DBD::mysql::BEGIN() called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 0
            eval {...} called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 0
            require DBD/mysql.pm called at /usr/local/cpanel/cpanellogd line 62
            main::BEGIN() called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 0
            eval {...} called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/List/Util.pm line 0
    (internal death) Sat Sep 16 23:40:45 2006 [15797] error: Undefined subroutine &Scalar::Util::weaken called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBI.pm line 283.
            eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBI.pm line 280
            require DBI.pm called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/DBD/mysql.pm line 7
            DBD::mysql::BEGIN() called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/Scalar/Util.pm line 0
            eval {...} called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/Scalar/Util.pm line 0
            require DBD/mysql.pm called at /usr/local/cpanel/cpanellogd line 62
            main::BEGIN() called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/Scalar/Util.pm line 0
            eval {...} called at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/Scalar/Util.pm line 0
    I tried updating List::Util and Scalar but they both report up to date versions and won't force installs. Any ideas?
     
    #1 Avg-Joe, Sep 16, 2006
    Last edited: Sep 16, 2006
  2. tweakservers

    tweakservers Well-Known Member

    Joined:
    Mar 30, 2006
    Messages:
    379
    Likes Received:
    0
    Trophy Points:
    16
    what version of Perl you are running? Try upgrade it to 5.8.7 from layer1.cpanel.net and reinitiate the Cpanel upgrade after the perl upgrade completed.
     
Loading...

Share This Page