The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trouble using "Mail Trouble Shooter"

Discussion in 'E-mail Discussions' started by howard111, May 23, 2003.

  1. howard111

    howard111 Member

    Joined:
    May 23, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I am having trouble using the "Mail Trouble Shooter" in web host manager.

    When I enter an email address and click on DO IT, I get the following error:

    Legend
    Mail Routing Error
    Filter/Alias File
    SMTP Destination

    What can I do to resolve this so that I can determine email problems using Mail TRouble Shooter?

    Howard Brooks
    support@techvgroup.net

    cPanel.net Support Ticket Number:
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Try running /scripts/installgd

    cPanel.net Support Ticket Number:
     
  3. howard111

    howard111 Member

    Joined:
    May 23, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    test

    test

    cPanel.net Support Ticket Number:
     
  4. howard111

    howard111 Member

    Joined:
    May 23, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    MAIL TROUBLESHOOTER STILL WON'T WORK

    Followed instructions of Administrator Bdraco, but mail troubleshooter still doen't work. Same errors.
    In ssh session when running /scripts/installgd below is the result.
    Various errors that I can't comprehend.

    HELP!


    root@smf [~]# /scripts/installgd
    CPAN: Storable loaded ok
    Going to read /root/.cpan/Metadata
    Database was generated on Fri, 23 May 2003 00:13:31 GMT
    File::Spec is up to date.
    Digest::MD5 is up to date.
    Compress::Zlib is up to date.
    Archive::Tar is up to date.
    Data::Dumper is up to date.
    Net::Telnet is up to date.
    Net::Cmd is up to date.
    Term::ReadKey is up to date.
    Term::ReadLine::Perl is up to date.
    CPAN::WAIT is up to date.
    CPAN is up to date.
    Running install for module GD
    Running make for L/LD/LDS/GD-2.07.tar.gz
    CPAN: Digest::MD5 loaded ok
    CPAN: Compress::Zlib loaded ok
    Checksum for /root/.cpan/sources/authors/id/L/LD/LDS/GD-2.07.tar.gz ok
    Scanning cache /root/.cpan/build for sizes
    GD-2.07/
    GD-2.07/t/
    GD-2.07/t/GD.t
    GD-2.07/t/Polyline.t
    GD-2.07/t/test.out.1.png
    GD-2.07/t/test.out.2.png
    GD-2.07/t/test.out.3.png
    GD-2.07/t/test.out.4.png
    GD-2.07/t/test.out.5.png
    GD-2.07/t/test.out.6.png
    GD-2.07/t/test.out.7.png
    GD-2.07/t/test.out.8.png
    GD-2.07/t/test.out.9.png
    GD-2.07/t/Generic.ttf
    GD-2.07/t/frog.jpg
    GD-2.07/t/frog.xpm
    GD-2.07/t/test.out.8.png-1
    GD-2.07/t/test.out.8.png-2
    GD-2.07/t/test.out.8.png-3
    GD-2.07/t/test.out.8.png-4
    GD-2.07/t/test.out.8.png-5
    GD-2.07/t/tile.png
    GD-2.07/t/palettemap.png
    GD-2.07/t/test.out.10.png
    GD-2.07/GD/
    GD-2.07/GD/Polyline.pm
    GD-2.07/GD.pm
    GD-2.07/GD.xs
    GD-2.07/demos/
    GD-2.07/demos/brushes.pl
    GD-2.07/demos/font_list.png
    GD-2.07/demos/fonttest
    GD-2.07/demos/polys.pl
    GD-2.07/demos/fills.pl
    GD-2.07/demos/truetype_test
    GD-2.07/demos/shapes.pl
    GD-2.07/demos/copies.pl
    GD-2.07/demos/ttf.pl
    GD-2.07/demos/gd_example.cgi
    GD-2.07/demos/tile.png
    GD-2.07/demos/polyline.pl
    GD-2.07/demos/transform.pl
    GD-2.07/qd.pl
    GD-2.07/README
    GD-2.07/Makefile.PL
    GD-2.07/README.QUICKDRAW
    GD-2.07/typemap
    GD-2.07/bdf_scripts/
    GD-2.07/bdf_scripts/README
    GD-2.07/bdf_scripts/cvtbdf.pl
    GD-2.07/bdf_scripts/bdftogd
    GD-2.07/README.unix
    GD-2.07/ChangeLog
    GD-2.07/MANIFEST
    Removing previously used /root/.cpan/build/GD-2.07

    CPAN.pm: Going to build L/LD/LDS/GD-2.07.tar.gz


    NOTICE: This module requires libgd 2.0.12 or higher.
    it will NOT work with earlier versions.
    See www.cpan.org for versions of GD that are compatible
    with earlier versions of libgd.

    Type perl Makefile.PL -h for command-line option summary

    Where is libgd installed? [/usr/lib]

    Please choose the features that match how libgd was built:
    Build JPEG support? [y] y
    Build FreeType support? [y] y
    Build XPM support? [y] y

    If you experience compile problems, please check the @INC, @LIBPATH and @LIBS
    arrays defined in Makefile.PL and manually adjust, if necessary.

    Checking if your kit is complete...
    Looks good
    Unrecognized argument in LIBS ignored: 'libgd/lib'
    Writing Makefile for GD
    cp qd.pl blib/lib/qd.pl
    cp GD.pm blib/lib/GD.pm
    AutoSplitting blib/lib/GD.pm (blib/lib/auto/GD)
    cp GD/Polyline.pm blib/lib/GD/Polyline.pm
    /usr/bin/perl -I/usr/lib/perl5/5.6.1/i686-linux -I/usr/lib/perl5/5.6.1 /usr/lib/perl5/5.6.1/ExtUtils/xsubpp -typemap /usr/lib/perl5/5.6.1/ExtUtils/typemap -typemap typemap GD.xs > GD.xsc && mv GD.xsc GD.c
    cc -c -Ilocate libgd/include -I/usr/local/include -I/usr/local/include/gd -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -DVERSION=\"2.07\" -DXS_VERSION=\"2.07\" -fpic -I/usr/lib/perl5/5.6.1/i686-linux/CORE -DHAVE_JPEG -DHAVE_FT -DHAVE_XPM GD.c
    cc: libgd/include: No such file or directory
    GD.xs: In function `XS_GD__Image_stringFT':
    GD.xs:1777: structure has no member named `charmap'
    GD.xs:1783: `gdFTEX_CHARMAP' undeclared (first use in this function)
    GD.xs:1783: (Each undeclared identifier is reported only once
    GD.xs:1783: for each function it appears in.)
    GD.xs:1785: structure has no member named `charmap'
    GD.xs:1785: `gdFTEX_Unicode' undeclared (first use in this function)
    GD.xs:1787: structure has no member named `charmap'
    GD.xs:1787: `gdFTEX_Shift_JIS' undeclared (first use in this function)
    GD.xs:1789: structure has no member named `charmap'
    GD.xs:1789: `gdFTEX_Big5' undeclared (first use in this function)
    make: *** [GD.o] Error 1
    /usr/bin/make -- NOT OK
    Running make install
    make had returned bad status, install seems impossible
    File::Spec is up to date.
    Digest::MD5 is up to date.
    Compress::Zlib is up to date.
    Archive::Tar is up to date.
    Data::Dumper is up to date.
    Net::Telnet is up to date.
    Net::Cmd is up to date.
    Term::ReadKey is up to date.
    Term::ReadLine::Perl is up to date.
    CPAN::WAIT is up to date.
    CPAN is up to date.
    Tree::MultiNode is up to date.
    perlmod--Install done
    root@smf [~]#
    root@smf [~]#

    cPanel.net Support Ticket Number:
     
  5. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    Still have Mail Routing Error message.

    Anyone have solution ?

    cPanel.net Support Ticket Number:
     
  6. Host4u2

    Host4u2 Well-Known Member

    Joined:
    Mar 24, 2002
    Messages:
    248
    Likes Received:
    0
    Trophy Points:
    16
    I have the same problem on 3 servers (all using the most current Stable release). Running "/scripts/installgd", although it ran with NO errors, the issue was not resolved :confused:

    cPanel.net Support Ticket Number:
     
  7. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    Yes, the issue was not resolved yet :confused:

    cPanel.net Support Ticket Number:
     
  8. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    451
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Vancouver, Canada
    Same here. The Mail troubleshooter working. Running Stable versions of Cpanel on all servers.

    cPanel.net Support Ticket Number:
     
  9. pingo

    pingo Well-Known Member

    Joined:
    Nov 16, 2002
    Messages:
    430
    Likes Received:
    0
    Trophy Points:
    16
    I am allways running the stable versions of cpanel and it doesn't work here neither.

    John
     
  10. ksingh

    ksingh Active Member

    Joined:
    Mar 21, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    I am having the same problem. On one server it runs fine, on the other it gives problem.

    I tried one other thing. Running traceaddy.cgi in terminal mode. The output was

    --------------
    Can't call method "children" on an undefined value at traceaddy.cgi line 290, <ERRTRACE> line 70.
    --------------

    Need to change QUERY_STRING to some other text before running the script. The server where the script runs fine, also runs fine from terminal mode.

    I think some PERL guy should have a look over it

    K Singh
     
Loading...

Share This Page