The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trouble with cpbackup-exclude.conf file.

Discussion in 'Data Protection' started by crazyfish, Jul 2, 2010.

  1. crazyfish

    crazyfish Member

    Joined:
    Oct 11, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I have a few sites that the data never changes so I wanted to remove them from my daily backups as I already have an offsite copy but when I add the path to the cpbackup-exclude.conf it only skips the last entry in the file and backups all the other folders. Am I entering the paths wrong? I have 1 entry per line.

    skipthisfolder
    skipthisfolder2
    skipthisfolder3
     
    #1 crazyfish, Jul 2, 2010
    Last edited: Jul 2, 2010
  2. Miraenda

    Miraenda Well-Known Member

    Joined:
    Jul 28, 2004
    Messages:
    242
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Coralville, Iowa USA
    Which cpbackup-exclude.conf file are you editing? The one at /etc/cpbackup-exclude.conf or another one?

    For the path, are you providing the full path to the account with a wildcard so something like this:

    /home/user1/*
    /home/user2/*
    /home/user3/*

    You can also uncheck those accounts in WHM > Backup > Configure Backup > Select Specific Users "Select >>" button area. It should then no longer back up those users.
     
  3. crazyfish

    crazyfish Member

    Joined:
    Oct 11, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I was editing the one in my home directory (/home/username/cpbackup-exclude.conf). This account has other sites I want backed up so I don't want to simply remove the whole user from the backups.

    Guess I should try the /etc/cpbackup-exclude.conf file?
     
  4. Miraenda

    Miraenda Well-Known Member

    Joined:
    Jul 28, 2004
    Messages:
    242
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Coralville, Iowa USA
    Yes, I would suggest trying the one in /etc/cpbackup-exclude.conf and using wildcards (*) for the contents of the folder itself in the path, so /home/user/public_html/folder/* and so on.
     
  5. crazyfish

    crazyfish Member

    Joined:
    Oct 11, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    That didn't work at all. Every directory I listed got backed up.

    /home/user/dir1/*
    /home/user/dir2/*
    /home/user/dir3/*
     
  6. Miraenda

    Miraenda Well-Known Member

    Joined:
    Jul 28, 2004
    Messages:
    242
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Coralville, Iowa USA
    I'd suggest opening up a ticket with cPanel technical support at that point via WHM > Support Center > Contact cPanel area.
     
  7. crazyfish

    crazyfish Member

    Joined:
    Oct 11, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Figured I would update this since the problem has been fixed.

    My VPS host contacted cPanel and they corrected the issue, whatever it was, they didn't say.

    They used the /home/username/cpbackup-exclude.conf file and the format was:

    skipthisfolder
    skipthisfolder2
    skipthisfolder3
     
Loading...

Share This Page