sunnyd

Registered
Apr 26, 2010
1
0
51
Recently I've been having trouble with the FTP function in cPanel.
I'm using Filezilla FTP client to connect.
I believe I have all my account info typed in correctly as it shows the welcome message. But as soon as it shows the welcome message, i get dieconnected.
Anyone have any ideas on how to resolve this?

Thanks in advance.


Status: Resolving address of ftp.comfortchurch.org
Status: Connecting to 69.65.33.41:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 21:06. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER [email protected]
Error: Could not connect to server
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
Recently I've been having trouble with the FTP function in cPanel.
I'm using Filezilla FTP client to connect.
I believe I have all my account info typed in correctly as it shows the welcome message. But as soon as it shows the welcome message, i get dieconnected.
Anyone have any ideas on how to resolve this?

Thanks in advance.


Status: Resolving address of ftp.comfortchurch.org
Status: Connecting to 69.65.33.41:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 21:06. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER [email protected]
Error: Could not connect to server
I would try toggling the passive mode option in the FTP client software configuration.

If a firewall is in-use, try temporarily disabling the firewall to see if access is restored to normal.
 

Spiral

BANNED
Jun 24, 2005
2,018
8
193
This does sound like failure to use "Passive Mode" issue here ....

Aside from enabling it in your FTP program, you may also want to check the FTP server and make sure it's setup to allow passive mode as well.

Edit your /etc/pure-ftpd.conf file ...

Look for "PassivePortRange" and uncomment the line

Restart your Pure-FTPd (FTP Server) service

If running a firewall may need to open up the same port range