Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Trouble with Password-Protected Directory

Discussion in 'General Discussion' started by urantian, Mar 10, 2005.

  1. urantian

    urantian Well-Known Member

    Joined:
    Jan 26, 2005
    Messages:
    95
    Likes Received:
    1
    Trophy Points:
    158
    Location:
    Fayetteville, Arkansas
    cPanel Access Level:
    Root Administrator
    I set up a password-protected directory, using CPanel's WEBPROTECT, and am getting a consistent error when I attempt to access the directory.

    After the username and password are accepted, I receive an Internal Server Error. The ERROR_LOG contains this:

    [crit] [client (IP)] configuration error: couldn't check access. No groups file?: /private/(filename)

    The /ETC/GROUP file is properly configured for the username. The AuthUserFile referenced in the directory's .HTACCESS file also appears to be properly configured.

    What could be causing the trouble?

    ---Michael
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    It would help if you pasted the contents of the .htaccess file in the protected directory.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. urantian

    urantian Well-Known Member

    Joined:
    Jan 26, 2005
    Messages:
    95
    Likes Received:
    1
    Trophy Points:
    158
    Location:
    Fayetteville, Arkansas
    cPanel Access Level:
    Root Administrator
    Here is the .HTACCESS file:

    # -FrontPage-
    Options None

    order deny,allow
    deny from all
    allow from all
    require group authors administrators

    order deny,allow
    deny from all

    AuthType Basic
    AuthName "www.[domain].com"
    AuthUserFile "/home/[username]/.htpasswds/private/passwd"

    require valid-user
     
  4. urantian

    urantian Well-Known Member

    Joined:
    Jan 26, 2005
    Messages:
    95
    Likes Received:
    1
    Trophy Points:
    158
    Location:
    Fayetteville, Arkansas
    cPanel Access Level:
    Root Administrator
    My problem is partially solved. I found that the .HTACCESS file was missing an AuthGroupFile reference. However, I still have another problem.

    The server is not allowing Perl scripts to be run outside the CGI-BIN directory. The ERROR_LOG shows the following:

    Options ExecCGI is off in the directory: /[directory path...]

    I tried adding a <Directory> statement to the HTTPD.CONF file, but it doesn't change anything. How do I enable scripts for a specific directory?

    ---Michael
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice