The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trouble with "VirtualHost" directive

Discussion in 'General Discussion' started by puffy, Nov 22, 2007.

  1. puffy

    puffy Registered

    Joined:
    Nov 21, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    When I adding new accounts in WHM, he adding into /usr/local/apache/conf/httpd.conf the next:
    Code:
    <VirtualHost 1.2.3.4:[COLOR="Red"]80[/COLOR]>
    ...
    </VirtualHost>
    But my apache working on port 8081 and I want that whm wrote in httpd.conf the next:
    Code:
    <VirtualHost 1.2.3.4:[COLOR="Red"]8081[/COLOR]>
    ...
    </VirtualHost>
    I try to edit /var/cpanel/templates/apache1/vhost.default such as:
    Code:
    <VirtualHost[% FOREACH ipblock IN vhost.ips %] [% ipblock.ip %]:[COLOR="Red"]8081[/COLOR][% END %]>
    ...
    This way doesn't solved the problem.
    My apache version is 1.3.37 and NameVirtualHost directive is:
    Code:
    NameVirtualHost 1.2.3.4:8081
    Please help me to solve this problem.

    P.S. Sorry for my english =)
     
  2. yapluka

    yapluka Well-Known Member

    Joined:
    Dec 24, 2003
    Messages:
    301
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    France
    cPanel Access Level:
    Root Administrator
    In your WHM >> Tweak Settings, you can specify the port your apache listens to :
    This should fix your issue :)
     
  3. puffy

    puffy Registered

    Joined:
    Nov 21, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I'm change port to 8081, WHM wrote VirtualHost directive with 80 port again :(
     
Loading...

Share This Page