The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Troubleshooting 'License File Expired "FUT!"' Messages

Discussion in 'General Discussion' started by cPanelJared, Jan 3, 2013.

  1. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Feb 25, 2010
    Likes Received:
    Trophy Points:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    If you see a message like the one in the attached screenshot, it means that the date on the server is incorrect. "FUT!" in the license message is short for "FUTure," and it means that the server's date is either far in the future or far in the past. Here is the example message:

    Those long strings of numbers are actually timestamps in Linux epoch format. There are many epoch converters on the Web that you can find by doing a Google search for "linux epoch converter", but the one I most frequently use is this:


    Paste those numbers into the epoch converter to get real timestamps. In this case, we have:

    1357834736 == Thu, 10 Jan 2013 16:18:56 GMT

    1325694594 == Wed, 04 Jan 2012 16:29:54 GMT

    You can also use the date command with the -d switch and an at-sign (@) from any shell command prompt to get the same results:

    # date -d @1357834736
    Thu Jan 10 10:18:56 CST 2013
    # date -d @1325694594
    Wed Jan  4 10:29:54 CST 2012

    The first number is the date and time when the license file needs to be updated, which normally happens automatically without you being aware. The second number is the actual date and time on the server. As you can see, in this particular example, right now the server's date is about a year in the past.

    The way to fix this is to set the server's date to today's date, and make sure to set the correct year in the process. You can do this from the shell as root by using the Linux date command, which also sets the server's time. Its usage is fairly straightforward:

    # date --help
    Usage: date [OPTION]... [+FORMAT]
      or:  date [-u|--utc|--universal] [MMDDhhmm[[CC]YY][.ss]]
    To set it to today's date, January 3, 2013, at 17:15 UTC, I would use:

    # date -u 010317152013
    If you do not specify the -u switch, then the server's timezone that is already set will be used. You can learn everything there is to know about the date command by typing either of these two commands:

    # man date
    # date --help
    Note that on a Virtuozzo or OpenVZ VPS, the date cannot be set in the VPS container. It must be set in the hardware node that hosts the container. If you are the administrator of a VPS and you encounter this problem, you will need to ask the hardware node administrator to set the date for you.

    Also note that a clock that does not seem to stay set can be a sign of a hardware problem, especially a failing CMOS battery. If you set the date and time to a known good value, and it seems to drift within a fairly short period of time, you should ask your data center for help with the hardware, because an unstable clock can be a sign of a problem on the server's motherboard.

    Attached Files:

Share This Page