Trying out cPanel and having issues

Ian Daniels

Well-Known Member
Nov 3, 2016
69
1
8
Manchester
cPanel Access Level
Root Administrator
Hi,

I need some serious help, basically the story is

We are moving our website from a hosting company internal, I have built a server that is the same specs as it is currently using down to the OS

The OS is centos 7.2

The Cpanel version is (WHM 58.0) (trail) once I can get it working the company will purchase the licesne

The site uses wordpress

After the restore of the backup through Cpanel it has loaded all the home directories and Mysql data correctly (identical to the current server)

How ever I am unable to navigate to the new site by IP which I should be able to

All it is giving me is 404 not found, this is where I am stuck

The wordpress files (php) are listed where they should be and the config file is pointing towards the database.

But is seems to me that when I am inserting the IP it isn't being directed correctly

Can anybody help?
 

Ian Daniels

Well-Known Member
Nov 3, 2016
69
1
8
Manchester
cPanel Access Level
Root Administrator
Basically I have done a restore from another CPanel (hosted by another company) within the backup - restore a full backup

The files and databases are exactly the same (obviously apart from the IP's)
 

Ian Daniels

Well-Known Member
Nov 3, 2016
69
1
8
Manchester
cPanel Access Level
Root Administrator
OK I know what you are saying "Checking that domain at intodns.com" have you just done a lookup for mppglobal? (88.202.xx.xx)

If you have it will show you where the current server where everything is working. I am trying to spin it up on another server on a completely different IP

51.141.x.xx
 
Last edited by a moderator:

Ian Daniels

Well-Known Member
Nov 3, 2016
69
1
8
Manchester
cPanel Access Level
Root Administrator
- Removed -

The 404 is saying that it is not configured to your web directory. If\when you get the config correct, you will get a wordpress or apache error page.

Are you using Apache as your web server? what does the apache.conf file point to? Is it configured as a virtual site? or is it your default web site?

The default would point to /var/www/html/

It is also possible that there is a cPanel config for your web server.

Check your error log file or apache log files for more details.
/var/log/httpd/error_log
 

Infopro

Well-Known Member
May 20, 2003
17,090
519
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
No need to pull a thread from some other forum in here to this one, link removed. If you've transferred that account from one cPanel server to another, that path to var/www/html/ wouldn't be correct. The account should be located at home/username/.


Cloudflare? is that part of CPanel?
It's not. You would have added it to the current server or the old one. That account is using a CloudFlare IP address.

OK I know what you are saying "Checking that domain at intodns.com"
If you check it at that site, at bottom in the www A Record section you can see the CloudFlare IP being used.
 

Ian Daniels

Well-Known Member
Nov 3, 2016
69
1
8
Manchester
cPanel Access Level
Root Administrator
Story in a nut shell

The current website which is working is being turned off soon

I have built a server with cpanel installed so the data can be easily transferred

It was from a recovery

However when trying to access the site from the new IP it is giving me the 404 error
 

Infopro

Well-Known Member
May 20, 2003
17,090
519
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
Assuming you only restored the account from backup but not made any changes to it since that need to be saved for some reason, you might try terminating the account properly via WebHost Manager and go again from the top. We're missing something simple here I think.

You've got at least one Package setup on the server, no accounts. Create an account and give it that dedicated IP address as before. Visit that new account's cPanel and add an index.html to the public_html directory of the account. Now visit that IP address. Does the index.html open as expected? That should work as expected.