dasy

Registered
Sep 15, 2008
3
0
51
Hi-
I've run "/scripts/easyapache" and even recently done a "/scripts/upcp --force", however despite clicking off GD in the PHP options, it does not show up in the extensions list and gd_info() produces an undefined function error.

Loaded Modules: Array
(
[0] => xmlwriter
[1] => libxml
[2] => dom
[3] => xmlreader
[4] => xml
[5] => tokenizer
[6] => session
[7] => pcre
[8] => SimpleXML
[9] => SPL
[10] => SQLite
[11] => standard
[12] => Reflection
[13] => mysqli
[14] => mbstring
[15] => json
[16] => hash
[17] => filter
[18] => exif
[19] => date
[20] => curl
[21] => ctype
[22] => apache2handler
)
 

dasy

Registered
Sep 15, 2008
3
0
51
Also, I see that my php.ini file has this line, but commented out:
;;;extension=php_gd2.so

This must be for Windows since it falls under that heading. Where would I find info in a config file that this was installed?
 

dasy

Registered
Sep 15, 2008
3
0
51
Ok, answering my own question :p

It seems that because I was running easyapache on the command line it didn't warn me that the zlib module was required (or maybe it did and I didn't notice). When I configured through WHM, it alerted me to this. Problem fixed.
 

MUHAMMAD UMAIR

Registered
Jul 15, 2008
2
0
51
First of all u have to un comment this ;extension=php_gd2.so
like this in your php.ini file
Code:
extension=/usr/local/php_gd2.so    and give the full path where this php_gd2.so located.
And restart APACHE.