The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trying to install Mod Security 2 so I can run Pyxsoft

Discussion in 'Security' started by pski, Mar 24, 2015.

  1. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    However I am getting an error Mod Security 2 no installed. so I uninstalled Pyxsoft and attempted to install but got this error.

    ==========================================================
    root@server.ecommsrv1.net [~]# yum install mod_security mod_security_crs
    Loaded plugins: fastestmirror, security
    Setting up Install Process
    Loading mirror speeds from cached hostfile
    Resolving Dependencies
    --> Running transaction check
    ---> Package mod_security.x86_64 0:2.7.3-3.el6 will be installed
    --> Processing Dependency: httpd-mmn = 20051115 for package: mod_security-2.7.3-3.el6.x86_64
    --> Processing Dependency: httpd for package: mod_security-2.7.3-3.el6.x86_64
    --> Processing Dependency: libaprutil-1.so.0()(64bit) for package: mod_security-2.7.3-3.el6.x86_64
    --> Processing Dependency: libapr-1.so.0()(64bit) for package: mod_security-2.7.3-3.el6.x86_64
    ---> Package mod_security_crs.noarch 0:2.2.6-3.el6 will be installed
    --> Running transaction check
    ---> Package apr.x86_64 0:1.3.9-5.el6_2 will be installed
    ---> Package apr-util.x86_64 0:1.3.9-3.el6_0.1 will be installed
    ---> Package mod_security.x86_64 0:2.7.3-3.el6 will be installed
    --> Processing Dependency: httpd-mmn = 20051115 for package: mod_security-2.7.3-3.el6.x86_64
    --> Processing Dependency: httpd for package: mod_security-2.7.3-3.el6.x86_64
    --> Finished Dependency Resolution
    Error: Package: mod_security-2.7.3-3.el6.x86_64 (epel)
    Requires: httpd
    Error: Package: mod_security-2.7.3-3.el6.x86_64 (epel)
    Requires: httpd-mmn = 20051115
    You could try using --skip-broken to work around the problem
    ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
    sendmail-cf-8.14.4-8.el6.noarch has missing requires of sendmail = ('0', '8.14.4', '8.el6')
    ==========================================================

    I am really not sure what this all means.
     
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Why are you installing mod_sec on cPanel server through yum command ?

    Please try to install it through easy-Apache script and let us know if you are getting any error.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,698
    Likes Received:
    657
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  4. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    I ended up letting Selecting an Easy Apache Rebuild Package and afterwards ran sh install.sh and BAM!! Software installed!!

    Thanks
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,698
    Likes Received:
    657
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page