Trying to install svn and getting error about apache ver

Caro_baritek

Registered
Sep 28, 2015
3
1
3
Cusco
cPanel Access Level
DataCenter Provider
Hi guys,

I am looking to install svn on my centos7 with cpanel and I am getting this error:

Error: Package: mod_dav_svn-1.7.14-10.el7.x86_64 (base)
Requires: httpd >= 2.4.6-37
Error: Package: mod_dav_svn-1.7.14-10.el7.x86_64 (base)
Requires: httpd-mmn = 20120211x8664

and this is my apache version:

httpd -v
Server version: Apache/2.4.23 (Unix)
Server built: Jul 29 2016 08:42:41
Cpanel::Easy::Apache v3.34.3 rev9999

I understand that I need to upgrade my apache version to 2.4.6-37. I tried to used easyapache3 to perform the upgrade but this version is not available to install.

Question:
  • What is latest apache version supported by cPanel?
  • Should I install easyapache4 in order to get apache 2.4.6-37?

Thank you in advanced, I was searching the internet for answers but there are not good information in the last 2 years.

Regards,
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,211
363
I am looking to install svn on my centos7 with cpanel and I am getting this error:

Error: Package: mod_dav_svn-1.7.14-10.el7.x86_64 (base)
Requires: httpd >= 2.4.6-37
Error: Package: mod_dav_svn-1.7.14-10.el7.x86_64 (base)
Requires: httpd-mmn = 20120211x8664
Hello,

The installation method you are using isn't compatible with cPanel servers because the default Apache package provided with CentOS isn't utilized. The following thread offers provides information about the installation process on cPanel:

Installing Subversion on a cPanel server (running on CentOS 6.X)

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,211
363
I'm happy to see you were able to complete the installation. Thank you for updating us with the outcome.