The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trying to update yum...couple of issues...

Discussion in 'General Discussion' started by theonetrueace, Apr 11, 2014.

  1. theonetrueace

    theonetrueace Registered

    Joined:
    Dec 6, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    So let me start by saying I'm no Linux pro, I am just knowledgeable enough to be dangerous. I got a VPS running Cent which I tried updating today and got the following. A quick search yielded similar issues but no direct discussions on fixes. Any idea about the best course of action here? Thanks!

    Code:
    --> Processing Dependency: libx264.so.107()(64bit) for package: mplayer-1.0-0.48.svn20100703.el6.rf.x86_64
    --> Processing Dependency: libx264.so.107()(64bit) for package: mencoder-1.0-0.48.svn20100703.el6.rf.x86_64
    --> Finished Dependency Resolution
    Error: Package: ffmpeg-libpostproc-0.6.5-1.el6.rf.x86_64 (@dag)
               Requires: libavutil.so.50(LIBAVUTIL_50)(64bit)
               Removing: ffmpeg-0.6.5-1.el6.rf.x86_64 (@dag)
                   libavutil.so.50(LIBAVUTIL_50)(64bit)
               Updated By: ffmpeg-1.2.1-3.el6.x86_64 (amberdms-os)
                   Not found
               Available: ffmpeg-0.6.1-1.el6.rf.x86_64 (dag)
                   libavutil.so.50(LIBAVUTIL_50)(64bit)
               Available: ffmpeg-0.5.2-2.el6.rf.x86_64 (dag)
                   Not found
    Error: Package: mplayer-1.0-0.48.svn20100703.el6.rf.x86_64 (@dag)
               Requires: libx264.so.107()(64bit)
               Removing: x264-0.0.0-0.4.20101111.el6.rf.x86_64 (@dag)
                   libx264.so.107()(64bit)
               Updated By: x264-0.130-3.20130502git1db4621.el6.x86_64 (amberdms-os)
                   Not found
    Error: Package: ffmpeg-libpostproc-0.6.5-1.el6.rf.x86_64 (@dag)
               Requires: libavutil.so.50()(64bit)
               Removing: ffmpeg-0.6.5-1.el6.rf.x86_64 (@dag)
                   libavutil.so.50()(64bit)
               Updated By: ffmpeg-1.2.1-3.el6.x86_64 (amberdms-os)
                   Not found
               Available: ffmpeg-0.6.1-1.el6.rf.x86_64 (dag)
                   libavutil.so.50()(64bit)
               Available: ffmpeg-0.5.2-2.el6.rf.x86_64 (dag)
                   Not found
    Error: Package: ffmpeg-libs-1.2.1-3.el6.x86_64 (amberdms-os)
               Requires: libopenal.so.1()(64bit)
    Error: Package: mencoder-1.0-0.48.svn20100703.el6.rf.x86_64 (@dag)
               Requires: libx264.so.107()(64bit)
               Removing: x264-0.0.0-0.4.20101111.el6.rf.x86_64 (@dag)
                   libx264.so.107()(64bit)
               Updated By: x264-0.130-3.20130502git1db4621.el6.x86_64 (amberdms-os)
                   Not found
     You could try using --skip-broken to work around the problem
    ** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
    frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0
    mod_dav_svn-1.6.11-7.el6.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
    checkyum version 21.1
    
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It looks like you are using some custom repo files in the /etc/yum.repos.d directory. Did you add those for custom software? If so, you may want to consider removing the custom repo files, and only manually installing custom software directly with the RPM.

    Thank you.
     
  3. theonetrueace

    theonetrueace Registered

    Joined:
    Dec 6, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the response. I think I followed some tutorial which had me using the custom repo to install ffmpeg. The Dag repo now that you mention it. Is there some way to update everything except those items throwing the errors? I tried --skip-broken to no avail.

    - - - Updated - - -

    NM renamed dag and one other repo file to disable it and now the update is taking place. Thanks for your original fast response. I probably wouldn't have realized to look at the repos. Please feel free to lock/delete the thread. :)
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page