The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

turn off mod_gzip

Discussion in 'General Discussion' started by webraptor, Dec 30, 2005.

  1. webraptor

    webraptor Active Member

    Joined:
    Dec 25, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Hey, i would like to turn off mod_gzip from working into one of my sites directories.
    I know I can do that with .htaccess but i do not know how :(
     
    #1 webraptor, Dec 30, 2005
    Last edited: Dec 30, 2005
  2. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    Wherever you would want gzip to be turned off, perhaps you could try:

    <IfModule mod_gzip.c>
    mod_gzip_on No
    </IfModule>

    Let me know if this works for you

    Anup
     
  3. webraptor

    webraptor Active Member

    Joined:
    Dec 25, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    I don`t think it worked. I mean i get the same results as i previously got. :(
    They should have changed.
     
  4. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    It worked for me:


    With mod gzip
    GET / HTTP/1.1" 200 9747


    Without mod gzip

    GET / HTTP/1.1" 200 61395

    Anup
     
  5. webraptor

    webraptor Active Member

    Joined:
    Dec 25, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    And where exactly did U place that script for mod_gzip
    Also , can I turn off zend for that directory?

    I wnat to do this as I have a test installed on my server and want to get a page load test.

    Both settings above force my pageload.php to load first and then execute
    itself (I think). Then the reported time is a page generation time, not a page load time.

    Hope you understand my issue
     
    #5 webraptor, Dec 31, 2005
    Last edited: Dec 31, 2005
  6. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    Whereever you would like to turn off mod_gzip.

    If for the entire domain then within Virtual Host container

    If for a given directory then

    <Directory /path/to/disable/mod_gzip>

    <IfModule mod_gzip.c>
    mod_gzip_on No
    </IfModule>

    </Directory>

    do a httpd configtest before rstarting httpd.
    BTW did you rstart httpd after you made the changes? Know it is stupid to ask but still.

    Zend i am not aware

    Anup
     
  7. webraptor

    webraptor Active Member

    Joined:
    Dec 25, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Yes I did. But made some test and my problem is not form the server side but from the client side :)
     
  8. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet

    You mean you are trying to see file size by right clicking on browser end?
    If server is throwing right content forget the client.

    Anup
     
  9. webraptor

    webraptor Active Member

    Joined:
    Dec 25, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    I mean .. I have run some test from different locations around the globe and got different results for the script that was suppossed to change because of the mod_gzip ...

    I got good results from people with good connections and bad results from people with bad internet connections . Other things also have made me know now that the problem is caused 100% from the client side.

    thanks anyway for letting me know how I can turn off mod_gzip.

    Happy New year to all of you !!
     
Loading...

Share This Page