The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Turn off/on Message Failure & copies of outgoing messages per domain (VPS)

Discussion in 'E-mail Discussions' started by friedmayofan, Jul 18, 2014.

  1. friedmayofan

    friedmayofan Member

    Joined:
    Apr 21, 2011
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi Guys, (CENTOS 5.10 x86_64 hyper-v – WHM 11.44.0 (build 27))

    couldn't find this answer in docs, forum, net.

    A while back I turned on options to send me outgoing message delivery failure emails as well as copies of the failed messages. I usually meticulously document/log all settings changed, but didn't in this case. I can't for the life of me find where to turn this stuff off. Tweak settings, Exim Config, Contacts… Somewhere in the UI I know, but where?

    That is the primary goal, then, if possible, I would like to turn those back on for specific other domains (not the one with auto-responders that spammers love to spam).

    Any hints would be greatly appreciated.

    Thank you,
    friedmayofan
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    651
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you elaborate on what exactly is sent to you? For instance, is it possible you setup a filter or a custom Exim rule?

    Thank you.
     
  3. friedmayofan

    friedmayofan Member

    Joined:
    Apr 21, 2011
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi Michael,

    sorry, I didn't want to bloat the post. It's a copy of the message (one of various pro-forma autoresponders set-up in one of the users cpanel UI) that was failed to be delivered to the spammer's email, the header & content are all the same, except: the To field is "Mail Delivery System <Mailer-Daemon@my.vps.com>", instead of the bad email. Additionally I get one of these for each of those messages as well as:
    Code:
    header:)
    Mail Delivery System <Mailer-Daemon@my.vps.com>
    To: autorespx@domain.com
    Return-Path: <>
    Envelope-To: autorespx@domain.com
    Delivery-Date: Fri, 18 Jul 2014 04:39:12 -0700
    Received: from mailnull by my.vps.com with local (Exim 4.82) id abcd1X86VM-0004wd-Mj for autorespx@domain.com; Fri, 18 Jul 2014 04:39:12 -0700
    X-Failed-Recipients: advertisebz09xgbyz@gmail.com
    Auto-Submitted: auto-replied
    Message-Id: <Eabcd1X86VM-0004wd-Mj@my.vps.com>
    Mail delivery failed: returning message to sender
    
    (content:)
    
    This message was created automatically by mail delivery software.
    
    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:
    
    advertisebz09xgbyz@gmail.com
    SMTP error from remote mail server after RCPT TO:<advertisebz09xgbyz@gmail.com>:
    host gmail-smtp-in.l.google.com [173.194.64.27]:
    550-5.1.1 The email account that you tried to reach does not exist. Please try
    550-5.1.1 double-checking the recipient's email address for typos or
    550-5.1.1 unnecessary spaces. Learn more at
    550 5.1.1 http://support.google.com/mail/bin/a...py?answer=6596 du8si12625620obb.10 - gsmtp
    
    ------ This is a copy of the message, including all the headers. ------
    (then a copy of the original message:) 
    sometimes I also get one of these:
    Header:
    Code:
    Mail Delivery System <Mailer-Daemon@my.vps.com>
    To: autorespY@domain.com
    Return-Path: <>
    Envelope-To: autorespy@domain.com
    Delivery-Date: Fri, 18 Jul 2014 07:19:34 -0700
    Received: from mailnull by my.vps.com with local (Exim 4.82) id 1X890Y-0007GU-19 for autorespY@domain.com; Fri, 18 Jul 2014 07:19:34 -0700
    Auto-Submitted: auto-replied
    Message-Id: <E1X890Y-0007GU-19@my.vps.com>
    Warning: message 1X7iV7-00040s-M9 delayed 24 hours
     
    Content:
    Code:
    This message was created automatically by mail delivery software.
    A message that you sent has not yet been delivered to one or more of its
    recipients after more than 24 hours on the queue on my.vps.com.
    
    The message identifier is:     1X7iV7-00040s-M9
    The subject of the message is: RE: ***SPAM-G*** Kim Kardashian Revealed Her Secret
    The date of the message is:    Thu, 17 Jul 2014 03:01:21 -0700
    
    The address to which the message has not yet been delivered is:
    
     [email]scoopc548@business.telecomitalia.it[/email]
       Delay reason: SMTP error from remote mail server after end of data:
       host mail-abs.telecomitalia.it [217.169.121.14]:
       421 4.3.2 System not accepting network messages
    
    No action is required on your part. Delivery attempts will continue for
    some time, and this warning may be repeated at intervals if the message
    remains undelivered. Eventually the mail delivery software will give up,
    and when that happens, the message will be returned to you.
    However, many times I don't get this second message.

    I just checked for user/account filters and there are none about this.

    I'll check exim config, again, but I've done so many times. It's possible some random article caught my eye and I implemented a rule I suppose… my memory is strictly of UI options in WHM however… searching through my advanced config and the exim manual online, it looks like almost all is set to either cpanel or exim defaults.
    I guess I'll do some more digging later.

    Thanks again.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    651
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket if you want us to take a closer look to see where those emails might originate from. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  5. friedmayofan

    friedmayofan Member

    Joined:
    Apr 21, 2011
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi Michael,

    Here's the ticket #:

    5480793

    Thank you,
    friedmayofan
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    651
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    To update, the user was advised to set up a filter that redirects these emails into a special folder. This way, the emails are reviewable, but they will be separate and won't fill up the inbox.

    Thank you.
     
Loading...

Share This Page