djtetsu

Registered
Jul 15, 2022
2
0
1
Vietnam
cPanel Access Level
Website Owner
I am trying to fix my php flush() function and it is well documentated that Apache compressing (gzip) prevents this. I have outputted my phpinfo and sure enough gzip is enabled (listed under Phar(?) stuff... I have tried to disabling compression in cpanel->optimize website , and also tried adding in entries in php.ini
output_buffering = Off
zlib.output_compression = Off
But nothing.

How to disable ?
Thank you for your help.
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,498
1,971
363
cPanel Access Level
Root Administrator
Hey there! It sounds like you're doing everything correctly to disable this. If you check your PHP Info page, can you confirm the additional php.ini where you added those values is being properly read?

If so, it might be best to submit a ticket to our team so we can check this directly on the system with the issue.
 

djtetsu

Registered
Jul 15, 2022
2
0
1
Vietnam
cPanel Access Level
Website Owner
Thanks.

Hmm I can't get my variables to be registered from any php.ini (that I've tried).

In my phpinfo shows

Loaded Configuration File/opt/cpanel/ea-php74/root/etc/php.ini

In this file I've verified that those 2 params are set to off, but under phar.. in my phpinfo it shows gzip compression is enabled.

gzip compressionenabled

and also shows

output_bufferingno valueno value

I've tried setting those 2 variables as off in php.ini in my /public_html/domainname.com under what is auto generated by cpanel , but still ignored.

I've restarted apache everytime.

Thank you for your help!