Turning off the logging of 404.shtml in error_log

craigedmonds

Well-Known Member
Oct 29, 2007
113
0
66
Europe
cPanel Access Level
Root Administrator
Twitter
Can someone please tell me how to stop these errors being logged into usr/local/apache/logs/error_log?

[Thu Sep 26 13:34:08 2013] [error] [client 37.59.67.192] File does not exist: /home/philotra/public_html/404.shtml, referer: http://www.pillipinos.com/wp-login.php

When I am tailing the log there is far too much "noise" from the entries and its not really needed.

There are 550 sites on the server and i do not want to go and put a 404.shtml file into each of the either.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

Are you attempting to disable logging the occurrences of a file not existing? Or, are you attempting to ensure the custom 404 pages are in place for all accounts?

Thank you.
 

craigedmonds

Well-Known Member
Oct 29, 2007
113
0
66
Europe
cPanel Access Level
Root Administrator
Twitter
I need to "mute" the logging for the 404.shtml files for my sanity as there are so many its really difficult to see whats going on in the usr/local/apache/logs/error_log

The alternative would be to "force" 404.shtml file I guess but I dont want to overwrite peoples custom 404 error pages, is there a way to do this?