The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Turning Register Globals ON

Discussion in 'General Discussion' started by d-woo, Aug 11, 2003.

  1. d-woo

    d-woo Well-Known Member

    Joined:
    Aug 9, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Hi All.

    I'm using WHM 7.2.0 cPanel 7.2.1-R108
    RedHat 7.3 - WHM X v2.1 and am new to cPanel. I'm switching (converting now...slowly) from Plesk and have heard great things about cPanel.

    I'm aware that my scripts should be written in such a way that Register Globals does not need to be on, but I do not see where to turn it on.

    In phpinfo it shows the path to php.ini to be /usr/lib

    I do not have a php.ini file in /usr/lib but rather in /usr/local/lib (and of course /etc)

    in both php.ini files Register Globals is already showing to be ON. I have not made any changes to php.ini, because I did not make any changes....but, I restarted Apache anyhow...no changes in the phpinfo.

    How do I change Register Globals to ON (where is the OFF setting coming from)?

    Thanks guys!

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  2. d-woo

    d-woo Well-Known Member

    Joined:
    Aug 9, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    I found the solution...for anyone else with this problem in the future...

    Uncommented these two lines in /etc/httpd/conf/httpd.conf:
    209:#LoadModule php4_module libexec/libphp4.so
    241:#AddModule mod_php4.c
    Restarted httpd.

    cPanel.net Support Ticket Number:
     
  3. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    If you had phpsuexec running, you don't anymore.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page