*tutorial* How to fix unlimited quotas and 0.00 disk usage problem

vmicovic

Well-Known Member
Sep 4, 2007
95
0
56
hello

the problem... quotas unlimited..

1./scripts/upcp --force

2.server reboot

3./scripts/fixquotas

problem solved :D


hm, i have REDHAT Enterprise 4 and doo like said in first post and all pass, but have still 0 disk space for each user.
quotacheck: Checked 3192 directories and 42333 files

Can i fix somehow this without reboot ?

and i doo same think on another servers including fbsd and on all work, but only on this REDHAT don`t want ..

tnx. for advice
 

Attachments

Last edited:

dantium

Member
Nov 28, 2007
9
0
51
Quotas fixed on some, still unlimited on others...

After following these instructions and updating to the latest cPanel/WHM several accounts were fixed but a few still have the unlimited quota issue.

Has anyone got any ideas on this? Its been bugging me for over a week now.

Running Centos 5, WHM 11.11.0, cPanel 11.16.0-R18450

Thanks -Dan
 

4u123

Well-Known Member
PartnerNOC
Jan 2, 2006
877
15
168
This continues to be an ongoing issue for us. In fact, the quotas resetting themselves to "unlimited" problem has been around for a very long time. I think cpanel would argue that the issue is with the quotas system and not with cPanel itself, nevertheless, its a common and repetetive issue on cpanel servers. I've been on a few linux user forums and I've not seen anyone complaining about quotas being reset on servers not running cpanel.

I'm back here in the forums again because I've got yet another server where all the accounts are showing as "unlimited". Usually I run /scripts/fixquotas and this resolves it - until the next time it happens. Its very anoyying because any customers who have purchased extra disk space end up being reset back to the quota for their particular plan, so we end up with complaints that they have run out of space.

I notice there are a great number of forum posts from people who had this problem, used the info in this article or another and considered the issue resolved. I would argue that the problem is never resolved and will always return later. Judging by the volume of people who experience this, I'd say its a widespread issue that demands some attention from the cpanel developers.
 

ccsoh

Registered
Mar 8, 2007
1
0
151
Quota Problem, /scripts/fixquotas no help. [fix]

Well I figured I would post this here as it seems to be a previously un answered problem, and this may help someone at some time.

Recently we faced the common cpanel quotas problem, 0mb used and unlimited quota. No problem, run /scripts/fixquotas right? No. Doing this did nothing to aid our problem. After a bit of snooping around and trial and error here is how we managed to fix it.

Note: Follow my instructions at your OWN risk. If you do this and somehow mess things up I am not to be held responsible. This shouldn't really harm anything even if it isn't the solution but still.. be warned.

First run "quotacheck -avugm", you should receive "quotacheck: Can't find filesystem to check or filesystem not mounted with quota option." If not you don't have the same problem.

Next step is to open fstab, type pico /etc/fstab.
The first line will probably look something like this:
"/dev/VolGroup00/LogVol00 / ext3 defaults 1 1"

What we want to do is change "defaults" to "usrquota".

Now save (ctrl + X, Y, Enter) and run "mount -o remount /".

Now run "quotacheck -avugm" once more. This time it should run through quotacheck normally.

After it is done running (and it may very well take quite a long time) you should get:

"Old group file not found. Usage will not be substracted.
done
quotacheck: Checked xxxx directories and xxxx files"

This is a good thing. Now run run "quotaon /"

Now your space used should be correct, but quotas may still be unlimited.

This isn't a problem, just run good old /scripts/fixquotas and let it run through. It will probably run quotacheck again but it won't hurt anything. And when it's done your quotas should be working as normal.

If this helped, great, but I make no guarantees. Just wanted to share what worked for me.

...Yes, I wrote this myself.
This worked exactly as it was said it would. We were having the disk usage showing 0MB for all of our accounts, and quota as unlimited for most of the accounts. Did as explained and everything worked perfect. :D

Thank you CollateralFX
 

cgest

Registered
PartnerNOC
Jan 27, 2005
4
0
151
Hi,

Joel M you are the Best!! :D

That solution works just fine!!

Very thanks...
 

youclickpc

Registered
Mar 16, 2010
1
0
51
VPS Quota Problems

Hi,

I can't follow the above tutorial because I'm on a VPS.
My fstab has
Code:
none    /dev/pts        devpts  rw      0       0
My datacenter has enabled level 2 quotas and I still get
Code:
No filesystems with quota detected.
when ever I try to run /scripts/fixquotas.

I tried to change the /etc/sysconfig/vz-scripts/3.conf file but this doesn't exist in my VPS.

My Server is CENTOS 5.4 x86_64
cPanel 11.25.0-R43473 is my cPanel version.

Does anyone have a solution for VPSs?

Thanks,
Adam.
 

joseav

Registered
Jun 20, 2011
2
0
51
Hello:

This works for me:

Enable Second-level Quotas

In Main Server:

stop container

The session below turns on second-level quotas for Container 101:



# vzctl set 101 --quotaugidlimit 100 --save

Unable to apply new quota values: ugid quota not initialized

Saved parameters for Container 101

# vzctl stop 101; vzctl start 101

Stopping Container ...

Container was stopped

Container is unmounted

Starting Container ...

Container is mounted

Adding IP address(es): 192.168.1.101

Hostname for Container set: ct101

Container start in progress...


/scripts/fixquotas