Two-factor authentication failed for WHM (and how to solve it)

Feb 29, 2016
14
0
1
Sweden
cPanel Access Level
Website Owner
As the topic states, two-factor authentication failed today, the codes generated by Googles app were no longer accepted.
I haven't figured out as to why it failed as much as actually trying to get back into WHM. I couldn't find anything in the documentation so I had to research it and found that renaming theyaml-file in /var/cpanel/authn/twofactor-auth sloved the problem.

Hopefully this will help if anyone else stumbles on this problem.
 
Feb 29, 2016
14
0
1
Sweden
cPanel Access Level
Website Owner
FYI, I'd neglected to sync server time, this will always cause this problem. Is there a reason why there is a button for set time zone and one for sync time? If you change time zone it should be obvious that you want the time synced too..?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
FYI, I'd neglected to sync server time, this will always cause this problem. Is there a reason why there is a button for set time zone and one for sync time? If you change time zone it should be obvious that you want the time synced too..?
Hello :)

I'm happy to see you were able to determine the cause of the problem. It's possible that some administrators prefer to use a custom date/time on their OS that does not sync to the actual time. That said, you could open a feature request for an additional check box under the "Change Time Zone" button that automatically syncs the time.

Submit A Feature Request

Thank you.