The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Two Factor Authentication Invalid Code Error

Discussion in 'Security' started by Michael Smith, Feb 18, 2017.

  1. Michael Smith

    Michael Smith Registered

    Joined:
    Sep 10, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    United Kingdom
    cPanel Access Level:
    Root Administrator
    Hey guys,

    Last week n a bit ive been having issues with the 2 factor on WHM.

    When i set the 2 factor up the code works. It will continue to work for a few hours then it will start saying invalid code. I then have to login to ssh and action

    whmapi1 twofactorauth_disable_policy

    login and set it up again.

    at first i thought it was system time thing however we have other software on the server using 2 factor auth that works fine. So tried a different device to generate the codes and the same thing happens.

    Is there any way i can diagnose this better ? a log that shows why it failed ??

    Thanks in advanced
     
  2. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    588
    Likes Received:
    88
    Trophy Points:
    153
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Try checking this one:

    /usr/local/cpanel/logs/secpol_log
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,286
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you let us know the version of cPanel installed on the system? Also, do you notice any output to /usr/local/cpanel/logs/error_log when this happens?

    Thank you.
     
Loading...

Share This Page