The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Two Home Partitions

Discussion in 'General Discussion' started by jnetsurfer, Sep 21, 2004.

  1. jnetsurfer

    jnetsurfer Member

    Joined:
    Feb 20, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have two resellers in WHM, and two home partitions (/home and /otherhome). Up until a few weeks ago, when either reseller created an account, it went into /home, and one of the resellers had to use the "rearrange accounts" function to move his accounts to /otherhome. Suddenly, both reseller's accounts are defaulting to /otherhome.

    I think this changed because /otherhome has more free space than /home... But I'm not sure

    Is there any way I can force reseller's accounts to go into one or the other directory? Or, if not, can I force all acounts to be created in /home by default, and then moved (rearranged) to /otherhome if desired? (In other words, I don't want the first reseller to have any access to /otherhome).

    -Josh
     
  2. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    WHM automatically uses any directory with home in it's name as a home directory, and by default chooses the one with the most space.

    You can change these settings in WHM's "edit setup" under "server setup".
     
  3. jnetsurfer

    jnetsurfer Member

    Joined:
    Feb 20, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Under "Edit Setup", I have "/home" listed as "Default Home Directory". Yet new accounts still appear on /otherhome

    How do I disable the defaulting to the partition with the most free space?
     
  4. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    I believe if you set the "Home Directory Prefix" blank, it will only use /home. Maybe try setting it to something that doesn't exist, like blank.

    I haven't experimented with that setup much.
     
Loading...

Share This Page