vacancy

Well-Known Member
Sep 20, 2012
529
204
93
Turkey
cPanel Access Level
Root Administrator
Hello
When I want to install cpanel on Ubuntu 20.04, I see the following error and the installation cannot be done.

***

[2022-05-30 14:39:15 +0000] [62279] (DEBUG): Cpanel::Exception::FeatureNotEnabled/(XID pdjkhe) “PHP” is not installed on the system.
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): at /usr/local/cpanel/Cpanel/ProgLang/Supported/php.pm lin e 118.
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): Cpanel::ProgLang::Supported::php::new("Cpanel::Prog Lang::Supported::php", "parent", Cpanel::ProgLang=HASH(0x565378e70450)) called at /usr/local/cpanel/Cpanel/ ProgLang.pm line 125
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): Cpanel::ProgLang::new("Cpanel::ProgLang", "type", " php") called at /etc/apt/universal-hooks/multi_pkgs/Post-Invoke/ea-php__WILDCARD__/011-migrate_extension_to _pecl_ini.dpkg-new line 34
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): !!!! “/etc/apt/universal-hooks/multi_pkgs/Post-Invoke/ea-p hp__WILDCARD__/011-migrate_extension_to_pecl_ini.dpkg-new --pkg_list=\/tmp\/apt\.4964bddacf8631386fdb8ad156 d7fb3a\.txn\-pkgs” did not exit cleanly: 65280
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): Service Status
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): Found 0 versions of PHP-FPM:
[2022-05-30 14:39:15 +0000] [62279] (DEBUG):
[2022-05-30 14:39:15 +0000] [62279] (DEBUG):
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): apache_php_fpm restarted successfully.
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): E: Sub-process /usr/bin/dpkg returned an error code (1)
[2022-05-30 14:39:15 +0000] [62279] (DEBUG):
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): Often errors like this can be resolved by running `apt upd ate`
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): Loading profile …
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): The system is resolving package dependencies and conflicts . This may take some time …
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): … done!
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): Installing …
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): - ssystem [EXIT_CODE] '/usr/local/bin/ea_install_profile' exited with 25
[2022-05-30 14:39:15 +0000] [62279] (DEBUG): - ssystem [END]
[2022-05-30 14:39:15 +0000] [62279] ( INFO): Completed execution of “/usr/local/bin/ea_install_profile --in stall /etc/cpanel/ea4/profiles/cpanel/default.json” in 17.793 second(s)
[2022-05-30 14:39:15 +0000] [62279] (ERROR): Could not install default EA4 profile
[2022-05-30 14:39:15 +0000] [62279] (FATAL): Failed to install EA4
[2022-05-30 14:39:15 +0000] [61707] (FATAL): The background process “EA4 Install” failed with a fatal error : The subprocess reported error number 1 when it ended.
2022-05-30 14:39:15 44 [43124] ( INFO): cPanel is here to help! Our Technical Support team is just a clic k away at https://support.cpanel.net/ or you can contact Customer Service via email [email protected]
2022-05-30 14:39:15 118 [43124] (FATAL): The system failed to run the /usr/local/cpanel/scripts/cpanel_ini tial_install script.
 
Last edited by a moderator:

vacancy

Well-Known Member
Sep 20, 2012
529
204
93
Turkey
cPanel Access Level
Root Administrator

vacancy

Well-Known Member
Sep 20, 2012
529
204
93
Turkey
cPanel Access Level
Root Administrator
Hi

Cpanel technicians examined the issue and found that the apache2-utils package installed with the operating system was causing a conflict with the ea4 installation. After removing the apache2-utils package, the installation is complete.

I created my server by choosing ubuntu 20.04 ready installation over vultr, probably this package comes automatically in this installation. I have suggested a fix for these packages that may conflict in the installation software, I hope this fix will be applied in the next versions.