Zazoos1

Well-Known Member
Jan 1, 2004
49
0
156
Hello,

I received an email from the server which said:
'The version of perl you are running (v5.8.7) is too old. There are known problems that cannot be worked around with this version of perl. It is HIGHLY recommended that you upgrade to v5.8.8 or later. '

Unfortunately, the instructions to do this failed miserably and seemed to have broken Perl altogether and we had to completely delete our old Perl installation, reinstall from scratch, and then rebuild every single Perl module that CPanel required in order to get things working again.

But now our mail server is not processing any emails. I get the following when I restart exim:


Sep 3 08:32:02 server exim: exim shutdown succeeded Sep 3 08:32:03 server exim: antirelayd shutdown succeeded Sep 3 08:32:04 server exim: spamd shutdown succeeded Sep 3 08:32:05 server exim: /usr/sbin/exim: error while loading shared libraries: libperl.so: cannot open shared object file: No such file or directory Sep 3 08:32:05 server exim: exim startup failed Sep 3 08:32:05 server exim: /usr/sbin/exim: error while loading shared libraries: libperl.so: cannot open shared object file: No such file or directory Sep 3 08:32:05 server exim: exim startup failed Sep 3 08:32:07 server exim: antirelayd startup succeeded Sep 3 08:32:11 server exim: spamd startup succeeded exim has failed, please contact the sysadmin.


Can anyone please offer any suggestions, as I am not sure what I am reading and my server admin is out of packet until much later today. Any help is appreciated.