The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unable to allocate any listen sockets on host (null) port 9418

Discussion in 'General Discussion' started by epanagio, Jul 31, 2014.

  1. epanagio

    epanagio Well-Known Member

    Joined:
    May 26, 2012
    Messages:
    50
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Website Owner
    I issue:
    PHP:
    <path>/git-daemon --syslog --base-path=<path>git --export-all --detach --verbose --enable=receive-pack
    but when I check with
    PHP:
    ps -grep git
    it is not running.

    The log shows
    PHP:
    unable to allocate any listen sockets on host (nullport 9418
    I am running a firewall and issuing
    PHP:
    service iptables status grep 9418
    I get
    PHP:
    30   ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:9418
    Of course when I try to push using my git client I get an error.

    I just don't understand what I am missing here. How can I resolve the error from the log?

    <EDIT>
    Also the command
    shows
     
    #1 epanagio, Jul 31, 2014
    Last edited: Jul 31, 2014
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Do you experience the same issue when temporarily disabling your firewall completely? Note that you may want to post this question on a forum dedicated to discussions of GIT or CentOS, as this is not necessarily related to cPanel so you may not receive as much user-feedback here.

    Thank you.
     
  3. epanagio

    epanagio Well-Known Member

    Joined:
    May 26, 2012
    Messages:
    50
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Website Owner
    I tried it with iptables turned off and I received the same error in the log.

     
Loading...

Share This Page