Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Unable to build apache2.2.14 w/php 5.2.12 in freebsd 6.2

Discussion in 'EasyApache' started by nyjimbo, Jan 16, 2010.

  1. nyjimbo

    nyjimbo Well-Known Member

    Jan 25, 2003
    Likes Received:
    Trophy Points:
    New York
    Running cPanel 11.25.0-C42400 - WHM 11.25.0 - X 3.9 FREEBSD 6.2 i386 standard just tried to do EasyApache in WHM to go from apache 2.2.13 w/php.5.2.11 to apache2.2.14 w/php 5.2.12 in freebsd 6.2

    Seems to start ok but then comes up with some kind of error on "ensurepkgs":

    Distilled successfully
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1263656471' !!
    Ouput from '/bin/sh -c "ulimit -a"':
    cpu time (seconds, -t) unlimited
    file size (512-blocks, -f) unlimited
    data seg size (kbytes, -d) 524288
    stack size (kbytes, -s) 65536
    core file size (512-blocks, -c) 0
    max memory size (kbytes, -m) 524288
    locked memory (kbytes, -l) unlimited
    max user processes (-u) 5547
    open files (-n) 11095
    virtual mem size (kbytes, -v) 524288
    sbsize (bytes, -b) unlimited
    !! Creating backup of working apache in '/usr/local/apache.backup'. !!
    !! Backup of working apache complete. !!
    Checking that all tarballs are present and up to date.
    !! Downloading '/var/cpanel/perl/easy/Cpanel/Easy/Apache/' !!

    !! Downloading '/var/cpanel/perl/easy/Cpanel/Easy/PHP5/' !!

    !! Downloading '/var/cpanel/perl/easy/Cpanel/Easy/PHP5/' !!

    Checking that all packages are present and up to date.
    !! No method to auto repair package system !!

    !! Please visit EaError < AllDocumentation < TWiki for help with this error. !!

    !! Restoring original working apache !!

    !! Executing '/scripts/initsslhttpd' !!
    !! Restarting 'httpd' ... !!
    !! 'httpd' restart complete. !!
    Building global cache for cpanel...Done
    !! Executing '/scripts/initfpsuexec' !!
    !! Executing '/scripts/initsslhttpd' !!
    Compiling report...
    Sending report (18 bytes)...
    !! If you want to create a support ticket with cPanel regarding this please reference 'BuildAP Report Id':
    '3016109' !!

    Report processed.
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1263656471' !!

    It seems "!! No method to auto repair package system !!" is the culprit but we have not had any problems with this system until now and we just ran upcp manually before this to go from 42399 to 42400 and it worked fine.

    Anyone else having this problem under Freebsd (6.2) ?
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #1 nyjimbo, Jan 16, 2010
    Last edited: Jan 16, 2010

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice