Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Unable to CHMOD a dir back to 755

Discussion in 'General Discussion' started by Xiode, Jul 16, 2007.

  1. Xiode

    Xiode Well-Known Member

    Joined:
    Oct 14, 2005
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    156
    Somehow one of my users managed to chmod public_html to 000.... I have no idea nor does he how this happened.. When I try to chmod it back to 755 i get this


    root@***** [/home/user]# chmod 0755 public_html
    chmod: changing permissions of `public_html': Operation not permitted



    Any ideas?
     
  2. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    8
    Trophy Points:
    193
    This may actually have been done automatically by your firewall if you have CSF installed ...

    This should help ...
    Code:
    chattr -i /home/user
    chmod 0755 /home/user
    
    (Sounds like the immutable flag has been set with chattr)
     
  3. Xiode

    Xiode Well-Known Member

    Joined:
    Oct 14, 2005
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    156
    how can I stop this from happening... and... How did it happen....
     
  4. Xiode

    Xiode Well-Known Member

    Joined:
    Oct 14, 2005
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    156
    I found the problem...

    Mon Jul 16 16:48:46 2007 lfd: *Script Alert* - A script in /home/user/public_html has sent an email 251 times within the last hour
    Mon Jul 16 16:48:46 2007 lfd: /home/user/public_html has been disabled


    I just took on a new rather large client. Is there a way I can stop this watch per client basis.. He is sending out news letters to around 1200 people...
     
  5. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    8
    Trophy Points:
    193
    There is a configuration option in CSF / LFD to disable the folder disable feature or you
    can set your maximum mail sending settings a bit higher so it's not quite so sensitive.
     
  6. Xiode

    Xiode Well-Known Member

    Joined:
    Oct 14, 2005
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    156
    Can I not set it on a per account basis? It would be more useful. I know this user isn't sending spam but I don't want the entire server to be able to send 1,500 emails an hr.
     
  7. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    8
    Trophy Points:
    193
    Are you asking about the email limit or disabling folder access as being "per account"?
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    You can ignore a particular path by adding the following to /etc/csf/csf.signore:

    /home/user/public_html

    Then restart lfd:

    service lfd restart
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice