Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to compile with modsecurity

Discussion in 'EasyApache' started by brent peacher, Sep 8, 2015.

  1. brent peacher

    brent peacher Registered

    Joined:
    Sep 8, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    lexington, ky
    cPanel Access Level:
    Root Administrator
    I'm failing when trying to run EasyApache with modsecurity. Attached is the end of the logfile... I was unable to upload the entire file as its too big for the up-loader on this forum. I'll be happy to send the full log if needed.

    Code:
    libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLINUX -D_REENTRANT -D_GNU_SOURCE -I/opt/xml2/include/libxml2 -I/usr/local/apache/include -I/usr/local/apache/include -I/usr/local/apache/include -DWITH_CURL -I/opt/xml2/include/libxml2 -DWITH_LUA -I/opt/lua/include -DWITH_PCRE_STUDY -DWITH_PCRE_JIT -DREQUEST_EARLY -DCACHE_LUA -DWITH_APU_CRYPTO -DWITH_REMOTE_RULES -I/opt/pcre/include -g -O2 -I/usr/local/apache/include -MT mod_security2_la-re_variables.lo -MD -MP -MF .deps/mod_security2_la-re_variables.Tpo -c re_variables.c -o mod_security2_la-re_variables.o >/dev/null 2>&1
    mv -f .deps/mod_security2_la-re_variables.Tpo .deps/mod_security2_la-re_variables.Plo
    /bin/sh ../libtool  --tag=CC   --mode=link gcc -I/usr/local/apache/include -I/usr/local/apache/include -I/usr/local/apache/include -DWITH_CURL -I/opt/xml2/include/libxml2 -DWITH_LUA -I/opt/lua/include -DWITH_PCRE_STUDY   -DWITH_PCRE_JIT -DREQUEST_EARLY  -DCACHE_LUA        -DWITH_APU_CRYPTO -DWITH_REMOTE_RULES -I/opt/pcre/include  -g -O2  -I/usr/local/apache/include  -no-undefined -module -avoid-version -R /opt/pcre/lib -lrt -lcrypt  -lpthread -lexpat -I/opt/xml2/include/libxml2 -L/opt/lua/lib   -o mod_security2.la -rpath /usr/local/modsecurity/lib mod_security2_la-acmp.lo mod_security2_la-apache2_config.lo mod_security2_la-apache2_io.lo mod_security2_la-apache2_util.lo libinjection/mod_security2_la-libinjection_html5.lo libinjection/mod_security2_la-libinjection_sqli.lo libinjection/mod_security2_la-libinjection_xss.lo mod_security2_la-mod_security2.lo mod_security2_la-modsecurity.lo mod_security2_la-msc_status_engine.lo mod_security2_la-msc_crypt.lo mod_security2_la-msc_geo.lo mod_security2_la-msc_gsb.lo mod_security2_la-msc_json.lo mod_security2_la-msc_logging.lo mod_security2_la-msc_lua.lo mod_security2_la-msc_multipart.lo mod_security2_la-msc_parsers.lo mod_security2_la-msc_pcre.lo mod_security2_la-msc_release.lo mod_security2_la-msc_remote_rules.lo mod_security2_la-msc_reqbody.lo mod_security2_la-msc_tree.lo mod_security2_la-msc_unicode.lo mod_security2_la-msc_util.lo mod_security2_la-msc_xml.lo mod_security2_la-persist_dbm.lo mod_security2_la-re_actions.lo mod_security2_la-re.lo mod_security2_la-re_operators.lo mod_security2_la-re_tfns.lo mod_security2_la-re_variables.lo /usr/local/apache/lib/libapr-1.la /usr/local/apache/lib/libaprutil-1.la -lcurl -I/opt/xml2/include/libxml2 -L/opt/xml2/lib -lxml2 -lz -lm -ldl -llua -L/opt/pcre/lib -lpcre 
    libtool: link: gcc -shared  -fPIC -DPIC  .libs/mod_security2_la-acmp.o .libs/mod_security2_la-apache2_config.o .libs/mod_security2_la-apache2_io.o .libs/mod_security2_la-apache2_util.o libinjection/.libs/mod_security2_la-libinjection_html5.o libinjection/.libs/mod_security2_la-libinjection_sqli.o libinjection/.libs/mod_security2_la-libinjection_xss.o .libs/mod_security2_la-mod_security2.o .libs/mod_security2_la-modsecurity.o .libs/mod_security2_la-msc_status_engine.o .libs/mod_security2_la-msc_crypt.o .libs/mod_security2_la-msc_geo.o .libs/mod_security2_la-msc_gsb.o .libs/mod_security2_la-msc_json.o .libs/mod_security2_la-msc_logging.o .libs/mod_security2_la-msc_lua.o .libs/mod_security2_la-msc_multipart.o .libs/mod_security2_la-msc_parsers.o .libs/mod_security2_la-msc_pcre.o .libs/mod_security2_la-msc_release.o .libs/mod_security2_la-msc_remote_rules.o .libs/mod_security2_la-msc_reqbody.o .libs/mod_security2_la-msc_tree.o .libs/mod_security2_la-msc_unicode.o .libs/mod_security2_la-msc_util.o .libs/mod_security2_la-msc_xml.o .libs/mod_security2_la-persist_dbm.o .libs/mod_security2_la-re_actions.o .libs/mod_security2_la-re.o .libs/mod_security2_la-re_operators.o .libs/mod_security2_la-re_tfns.o .libs/mod_security2_la-re_variables.o   -Wl,-rpath -Wl,/usr/local/apache/lib -Wl,-rpath -Wl,/opt/xml2/lib -Wl,-rpath -Wl,/opt/pcre/lib -Wl,-rpath -Wl,/usr/local/apache/lib -Wl,-rpath -Wl,/opt/xml2/lib -Wl,-rpath -Wl,/opt/pcre/lib -lrt -lcrypt -lpthread -lexpat -L/opt/lua/lib /usr/local/apache/lib/libapr-1.so /usr/local/apache/lib/libaprutil-1.so -lcurl -L/opt/xml2/lib /opt/xml2/lib/libxml2.so -lz -lm -ldl -llua -L/opt/pcre/lib /opt/pcre/lib/libpcre.so  -O2   -Wl,-soname -Wl,mod_security2.so -o .libs/mod_security2.so
    /usr/bin/ld: /opt/lua/lib/liblua.a(lapi.o): relocation R_X86_64_32 against `luaO_nilobject_' can not be used when making a shared object; recompile with -fPIC
    /opt/lua/lib/liblua.a: could not read symbols: Bad value
    collect2: ld returned 1 exit status
    make[2]: *** [mod_security2.la] Error 1
    make[2]: Leaving directory `/root/rpmbuild/BUILD/modsecurity-2.9.0/apache2'
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/root/rpmbuild/BUILD/modsecurity-2.9.0/apache2'
    make: *** [all-recursive] Error 1
    !! Done executing '/usr/local/cpanel/scripts/posteasyapache' !!
    !! '/usr/local/cpanel/scripts/posteasyapache 3.30.5 9999 2.2.31 0,5.4.44' failed with exit code '256' !!
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1441766047' !!
    
     
    #1 brent peacher, Sep 8, 2015
    Last edited by a moderator: Sep 8, 2015
  2. 24x7serversecurity

    24x7serversecurity Active Member

    Joined:
    Aug 31, 2015
    Messages:
    37
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi :),

    Are you trying to re-enable the mod_security?
    It appears that some libraries are not getting installed properly. You may need to open a Support ticket with cPanel.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,127
    Likes Received:
    1,366
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can try reinstalling the lua package via:

    Code:
    yum reinstall lua
    Let us know if this helps.

    Thank you.
     
Loading...

Share This Page