Unable to connect to port 25

chris0147

Well-Known Member
Aug 28, 2015
104
2
68
London
cPanel Access Level
Root Administrator
Hi all,

I have received the emails from cPanel notification alert as the exim has been failed.

Code:
Number of Restart Attempts: 816

Reason: Unable to connect to port 25 on 127.0.0.1: Connection refused: Died

The chkservd process attempts to connect to “127.0.0.1:25” in order to validate that this service is functioning. If you blocked connections with iptables or the “Host Access Control” interface in WHM, this failure may be a false positive.

To resolve this issue, either open the firewall to allow connections as the root user to “127.0.0.1:25” or disable checks for this service in WHM’s “Service Manager” interface with the “Configure Monitor Settings” link below.

Configure Monitor Settings:
https://server1.myserver.net:2087/scripts/srvmng#service-chkservd

Configure chkservd:
https://server1.myserver.net:2087/scripts2/tweaksettings?find=chkservd
I have been checked with tailwatchd and the exim is working fine as they has not been down.

There is something have to do with the firewall, iptables or Host Access Control which I am not really sure what I need to do.

Can you please advice me with what I have to do?

If you can give me the step to step with what I have to do, I will be very grateful.

Thanks in advance
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Hello,

Are you using any firewall management utilities such as CSF on this system? Or, do you have any custom iptables firewall rules configured? If not, and if no rules exist via "WHM >> Host Access Control", then I recommend reaching out to your data center or hosting provider to verify if there's anything filtering port 25 in their network or firewall rules.

Thank you.