Unable to create feature list

Dan_

Registered
Feb 2, 2016
2
0
1
UK
cPanel Access Level
Root Administrator
Hi,

We're having the following issue on a cPanel 54 server when trying to create a feature list as a reseller:

[2016-02-02 14:07:53 +0000] info [xml-api] Invalid featurelist name provided: "hello" is invalid for reseller "reselleruser". [create_featurelist] version [1].

We've tried running upcp and can't find any reason why this would be happening. It isn't just happening on a particular reseller, it happens on any.

Thanks
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
Are your creating these for your reseller, or by the reseller directly?
Are the creation attempts happening in the WHM UI, or via API calls?
 

Dan_

Registered
Feb 2, 2016
2
0
1
UK
cPanel Access Level
Root Administrator
They're happening when we create them for the reseller and when the reseller creates them.

They're being created through the WHM UI, I just pulled that line from the cPanel logs at the time it happened.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
I did some investigation. Reseller owned feature lists must be named: reseller_featurelist.

If my reseller name is 'ken' and I want to create a feature list named 'hello' then I must input 'ken_hello' in the feature list name field. Only root-enabled resellers are able to create feature lists that do not have a reseller name prefix. Feature lists without the reseller name prefix are considered global, available to all resellers on the system.

I filed case CPANEL-4039 to have the UI clarified regarding the requirements.
 
Last edited by a moderator: