The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to determine filesystems with quotas enabled

Discussion in 'General Discussion' started by Sergiu Tot, Mar 9, 2011.

  1. Sergiu Tot

    Sergiu Tot Well-Known Member

    Joined:
    Jul 17, 2007
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Cluj, Romania
    cPanel Access Level:
    Root Administrator
    On a fresh new server (FreeBSD 8.0, cPanel 11.28.83), in WHM > Initial Quota Setup, after clicking "Proceed" I get the following error:
    Code:
    Installing Default Quota Databases...
    Unable to determine filesystems with quotas enabled
    The quota support is enabled in kernel and quota is activated on /home partition. E.g.:
    Code:
    [root@web ~]# quota -v
    Disk quotas for user root (uid 0): 
         Filesystem   usage   quota   limit   grace   files   quota   limit   grace
              /home  821172       0       0           54178       0       0        
    [root@web ~]# 
    Any ideeas?
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    What does the /home entry in /etc/fstab look like?
     
  3. kopic

    kopic Registered

    Joined:
    Mar 31, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    hello.
    a have a same problem.
    Code:
    [15:28] [/] # uname -a
    FreeBSD ****.ru 8.1-STABLE FreeBSD 8.1-STABLE #0: Fri Nov 12 13:33:21 MSK 2010 user@domain.com:/usr/obj/usr/src/sys/WEBCORE amd64
    
    [15:32] [/] # less /sys/amd64/conf/
    /sys/amd64/conf/ is a directory
    [15:32] [/] # less /sys/amd64/conf/WEBCORE
    include GENERIC
    
    ident WEBCORE
    
    options NETGRAPH
    maxusers 512
    options QUOTA
    
    device pf
    options ALTQ
    options ALTQ_CBQ
    options ALTQ_RED
    options ALTQ_RIO
    
    makeoptions DEBUG=-g
    
    /dev/ar1s1d /usr/home ufs rw,userquota,groupquota 2 2
    
    [15:33] [/scripts] # ./fixquotas
    Installing Default Quota Databases...
    Unable to determine filesystems with quotas enabled
    any ideas?
     
    #3 kopic, Mar 31, 2011
    Last edited: Apr 1, 2011
  4. Sergiu Tot

    Sergiu Tot Well-Known Member

    Joined:
    Jul 17, 2007
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Cluj, Romania
    cPanel Access Level:
    Root Administrator
    Hello,

    Sorry for not answering. I opened a ticket and someone from cPanel support team solved my problem. Aparently the file /etc/fstab.quota was missing.
     
  5. kopic

    kopic Registered

    Joined:
    Mar 31, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    yes, i cann't find this file.
    Can i create this file?
     
  6. kopic

    kopic Registered

    Joined:
    Mar 31, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    On other server i find next files:

    [21:40] [/etc] # ll | grep fstab
    -rw-r--r-- 1 root wheel 328 12 май 2010 fstab
    -r--r--r-- 1 root wheel 477 27 янв 2010 fstab,v
    -rw-r--r-- 1 root wheel 272 27 янв 2010 fstab.quotas

    that good for quotas.
    But on this server i cann't find this files.
     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please do create the file:

    Code:
    touch /etc/fstab.quotas
    This should resolve the issue on your FreeBSD system.

    Of note, the prior ticket where this was resolved was ticket #1273670 as a reference.
     
Loading...

Share This Page