The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to initialize module EA 3

Discussion in 'EasyApache' started by bloatedstoat, Jun 2, 2016.

  1. bloatedstoat

    bloatedstoat Well-Known Member

    Joined:
    Jun 14, 2012
    Messages:
    78
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Victoria, Australia
    cPanel Access Level:
    Root Administrator
    Hello,

    Ran EA3 last night as I had a notification relating to security updates.

    I set the default native version to 5.6, the logfile at /home/cpeasyapache/src/php-5.6.22/error_log had these errors in it.

    Is this an EA3 issue?

    We're running CloudLinux 6.3 with CageFS, WHM 56.0 (build 22)


    Code:
    [02-Jun-2016 07:55:40 UTC] PHP Warning:  PHP Startup: PDO: Unable to initialize module
    Module compiled with module API=20121212
    PHP    compiled with module API=20131226
    These options need to match in Unknown on line 0
    
    [02-Jun-2016 07:55:40 UTC] PHP Warning:  PHP Startup: pdo_sqlite: Unable to initialize module
    Module compiled with module API=20121212
    PHP    compiled with module API=20131226
    These options need to match in Unknown on line 0
    
    [02-Jun-2016 07:55:40 UTC] PHP Warning:  PHP Startup: pdo_mysql: Unable to initialize module
    Module compiled with module API=20121212
    PHP    compiled with module API=20131226
    These options need to match in Unknown on line 0
    
    [02-Jun-2016 07:55:40 UTC] PHP Warning:  PHP Startup: imagick: Unable to initialize module
    Module compiled with module API=20121212
    PHP    compiled with module API=20131226
    These options need to match in Unknown on line 0
    
    [02-Jun-2016 07:55:40 UTC] PHP Warning:  PHP Startup: geoip: Unable to initialize module
    Module compiled with module API=20121212
    PHP    compiled with module API=20131226
    These options need to match in Unknown on line 0
    
    [02-Jun-2016 07:55:57 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/imagick.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20131226/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0
    Thank you.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Are you able to reproduce any error messages with your websites, or did you only notice this during the EasyApache build itself?

    Thank you.
     
  3. bloatedstoat

    bloatedstoat Well-Known Member

    Joined:
    Jun 14, 2012
    Messages:
    78
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Victoria, Australia
    cPanel Access Level:
    Root Administrator
    Nothing obvious to us Michael and we've had no contact from any clients so it appears limited to the EA3 build.
    Thanks.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You can review the following document regarding raw opts to see if any custom entries are enabled on your system:

    Raw Opts - EasyApache - cPanel Documentation

    Otherwise, let us know if you notice any error messages regarding PHP on your websites so we can troubleshoot further.

    Thank you.
     
  5. roliboli

    roliboli Active Member

    Joined:
    Sep 3, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Switzerland
    Hi Michael

    I have the same errors in error.log after switching from php 5.5 to php 5.6 in EA3. There are no rawopts.
    Code:
    [04-Jul-2016 23:15:01 Europe/Berlin] PHP Warning:  PHP Startup: pdo_sqlite: Unable to initialize module
    Module compiled with module API=20121212
    PHP    compiled with module API=20131226
    These options need to match
    in Unknown on line 0
    Do you have a solution?

    Thanks Roland
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Are you using any custom php.ini files for your accounts, or in a location such as /root/php.ini?

    Thank you.
     
Loading...

Share This Page