SOLVED Unable to install any options using easyapache4

otakudes

Active Member
Jun 19, 2020
26
5
3
USA
cPanel Access Level
Website Owner
I have a couple sites running cPanel 98.0.6 and suPHP. One site won't let me upgrade to php 8. Actually, it won't let me install anything using easyapache4. I think there is something wrong with my easyapache. Is there a way to remove it and reinstall it or force it to upgrade?
 

kodeslogic

Well-Known Member
PartnerNOC
Apr 26, 2020
453
217
118
IN
cPanel Access Level
Root Administrator
Can you please share the exact error you are getting at your end, It will help to assist you better.
 
  • Like
Reactions: cPRex

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
11,032
1,740
363
cPanel Access Level
Root Administrator
What @kodeslogic said - we would need some type of error, either from the EasyApache 4 interface in WHM, or from the main log at /usr/local/cpanel/logs/error_log in order to get you better details on how to fix this.

Since you have root access to the server you're also welcome to submit a ticket to our support team at any time so we can check the issue directly on the system.
 

otakudes

Active Member
Jun 19, 2020
26
5
3
USA
cPanel Access Level
Website Owner
There are no error messages. Say if I select a feature to install like PHP 8.0 but it could be anything, it won't do anything. When I try to provision it, it says nothing will be installed and no changes will be made. If if try to removed something, say PHP 7.3. I will do it, I've looked in the error log and nothing shows up that I can see.

Screen Shot 2021-08-30 at 15.06.05.png
Screen Shot 2021-08-30 at 15.07.46.png
 

otakudes

Active Member
Jun 19, 2020
26
5
3
USA
cPanel Access Level
Website Owner
cPanel CS was kind enough to solve my problem. I didn't follow all the steps to uninstall Imunify which created multiple versions of easyapache on my server. CS provided this page as a solution: