Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Unable to install any PEAR modules

Discussion in 'General Discussion' started by Serra, Jun 26, 2012.

  1. Serra

    Serra Well-Known Member

    Joined:
    Oct 27, 2005
    Messages:
    242
    Likes Received:
    13
    Trophy Points:
    168
    Location:
    Florida
    For some reason, I can't install any pear modules via cPanel:

    downloading OLE-1.0.0RC2.tgz ...
    Starting to download OLE-1.0.0RC2.tgz (13,981 bytes)
    .....done: 13,981 bytes
    Could not get contents of package "/root/tmp/pear/cache/OLE-1.0.0RC2.tgz". Invalid tgz file.
    Download of "pear/OLE" succeeded, but it is not a valid package archive
    Error: cannot download "pear/OLE"
    Download failed
    install failed


    I verified that /root/tmp/pear/cache/OLE-1.0.0RC2.tgz exists and is a valid archive. I tried several different packages and I can't install anything.
     
  2. Eric

    Eric Administrator
    Staff Member

    Joined:
    Nov 25, 2007
    Messages:
    751
    Likes Received:
    11
    Trophy Points:
    143
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Howdy,

    Could you issue a ticket for this? We need to review this a bit more.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,609
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello,

    While you are working on issuing a ticket, could you try the following to see the results:

    Code:
    pear channel-update pear.php.net
    This will update the PEAR channel.

    Then run this to see if your existing php.ini file might be the cause:

    Code:
    cd /usr/local/lib
    mv php.ini php.ini.bak120628
    /scripts/phpini
    At that point, please try to install the PEAR package to see the results. If it works, then please try the following to see the differences in the two php.ini files:

    Code:
    diff /usr/local/lib/php.ini /usr/local/lib/php.ini.bak120628
    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice