Unable to install cpanel on ubuntu 20.04

DevPlorer

Registered
Jan 20, 2022
2
0
1
India
cPanel Access Level
Root Administrator
Trying to setup cpanel on my VPS server(Ubuntu 20.04.3 LTS)
But ran into issues which following screen can explain.

Would appreciate your help in resolving this!

Code:
[my user]:/home# curl -o latest https://securedownloads.cpanel.net/latest && sh latest
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 65234  100 65234    0     0  78880      0 --:--:-- --:--:-- --:--:-- 78785
Verifying archive integrity... All good.
Uncompressing cPanel & WHM Installer...................
        ____                  _
    ___|  _ \ __ _ _ __   ___| |
   / __| |_) / _` | '_ \ / _ \ |
  | (__|  __/ (_| | | | |  __/ |
   \___|_|   \__,_|_| |_|\___|_|

  Installer Version v00120 r22c27bf61a5f3084426dbd26d81eb146ac6cb5ea

Installing  iproute2 ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
iproute2 is already the newest version (5.5.0-1ubuntu1).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
default-mysql-client : Depends: mysql-client-8.0 but it is not going to be installed
libmailutils6 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
libsnmp35 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
postfix-mysql : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
                 Depends: postfix (= 3.4.13-0ubuntu1.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Beginning main installation.
2022-01-20 12:48:20  106 [48530] ( INFO): cPanel & WHM installation started at: Thu Jan 20 12:48:20 2022!
2022-01-20 12:48:20  107 [48530] ( INFO): This installation will require 10-50 minutes, depending on your hardware and network.
2022-01-20 12:48:20  108 [48530] ( INFO): Now is the time to go get another cup of coffee/jolt.
2022-01-20 12:48:20  109 [48530] ( INFO): The install will log to the /var/log/cpanel-install.log file.
2022-01-20 12:48:20  110 [48530] ( INFO):
2022-01-20 12:48:20  111 [48530] ( INFO): Beginning Installation v3...
2022-01-20 12:48:20   92 [48530] (DEBUG):   Parsing command line arguments.
2022-01-20 12:48:20  124 [48530] ( INFO): Install type: standard
2022-01-20 12:48:20  292 [48530] ( INFO): Checking RAM now...
2022-01-20 12:48:20  340 [48530] ( INFO): Checking for any control panels...
2022-01-20 12:48:20   54 [48530] ( INFO): Running health checks prior to start.
2022-01-20 12:48:20  363 [48530] ( INFO): Checking for essential system files...
2022-01-20 12:48:20  393 [48530] ( INFO): The installation process will now set up the necessary empty cpanel directories.
2022-01-20 12:48:20 1093 [48530] (DEBUG):   - ssystem [BEGIN]: usermod -g 99 nobody
2022-01-20 12:48:20 1093 [48530] (DEBUG):     usermod: no changes
2022-01-20 12:48:20 1093 [48530] (DEBUG):   - ssystem [END]
2022-01-20 12:48:20   48 [48530] (DEBUG):   - ssystem [BEGIN]: sysctl fs.protected_regular=0
2022-01-20 12:48:20   48 [48530] (DEBUG):     sysctl: cannot stat /proc/sys/fs/protected_regular: No such file or directory
2022-01-20 12:48:20   48 [48530] (ERROR):   - ssystem [EXIT_CODE] 'sysctl' exited with 255
2022-01-20 12:48:20   48 [48530] (DEBUG):   - ssystem [END]
2022-01-20 12:48:20  142 [48530] (DEBUG):   - ssystem [BEGIN]: /usr/bin/apt-get update
2022-01-20 12:48:20  142 [48530] (DEBUG):     Hit:1 http://archive.canonical.com/ubuntu focal InRelease
2022-01-20 12:48:20  142 [48530] (DEBUG):     Hit:2 http://archive.ubuntu.com/ubuntu focal InRelease
2022-01-20 12:48:20  142 [48530] (DEBUG):     Get:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
2022-01-20 12:48:20  142 [48530] (DEBUG):     Get:4 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
2022-01-20 12:48:20  142 [48530] (DEBUG):     Fetched 228 kB in 1s (447 kB/s)
2022-01-20 12:48:21  142 [48530] (DEBUG):     Reading package lists...
2022-01-20 12:48:21  142 [48530] (DEBUG):   - ssystem [END]
2022-01-20 12:48:21  142 [48530] (DEBUG):   - ssystem [BEGIN]: /usr/bin/apt-get install -y libfile-fcntllock-perl
2022-01-20 12:48:21  142 [48530] (DEBUG):     Reading package lists...
2022-01-20 12:48:21  142 [48530] (DEBUG):     Building dependency tree...
2022-01-20 12:48:21  142 [48530] (DEBUG):     Reading state information...
2022-01-20 12:48:21  142 [48530] (DEBUG):     libfile-fcntllock-perl is already the newest version (0.22-3build4).
2022-01-20 12:48:21  142 [48530] (DEBUG):     You might want to run 'apt --fix-broken install' to correct these.
2022-01-20 12:48:21  142 [48530] (DEBUG):     The following packages have unmet dependencies:
2022-01-20 12:48:21  142 [48530] (DEBUG):      default-mysql-client : Depends: mysql-client-8.0 but it is not going to be installed
2022-01-20 12:48:21  142 [48530] (DEBUG):      libmailutils6 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:21  142 [48530] (DEBUG):      libsnmp35 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:21  142 [48530] (DEBUG):      postfix-mysql : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:21  142 [48530] (DEBUG):                      Depends: postfix (= 3.4.13-0ubuntu1.2) but it is not going to be installed
2022-01-20 12:48:21  142 [48530] (DEBUG):     E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
2022-01-20 12:48:21  142 [48530] (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/apt-get' exited with 100
2022-01-20 12:48:21  142 [48530] (DEBUG):   - ssystem [END]
2022-01-20 12:48:21  142 [48530] (DEBUG):   - ssystem [BEGIN]: /usr/bin/apt-get install -y libfile-fcntllock-perl
2022-01-20 12:48:21  142 [48530] (DEBUG):     Reading package lists...
2022-01-20 12:48:22  142 [48530] (DEBUG):     Building dependency tree...
2022-01-20 12:48:22  142 [48530] (DEBUG):     Reading state information...
2022-01-20 12:48:22  142 [48530] (DEBUG):     libfile-fcntllock-perl is already the newest version (0.22-3build4).
2022-01-20 12:48:22  142 [48530] (DEBUG):     You might want to run 'apt --fix-broken install' to correct these.
2022-01-20 12:48:22  142 [48530] (DEBUG):     The following packages have unmet dependencies:
2022-01-20 12:48:22  142 [48530] (DEBUG):      default-mysql-client : Depends: mysql-client-8.0 but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):      libmailutils6 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):      libsnmp35 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):      postfix-mysql : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):                      Depends: postfix (= 3.4.13-0ubuntu1.2) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):     E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
2022-01-20 12:48:22  142 [48530] (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/apt-get' exited with 100
2022-01-20 12:48:22  142 [48530] (DEBUG):   - ssystem [END]
2022-01-20 12:48:22  142 [48530] (DEBUG):   - ssystem [BEGIN]: /usr/bin/apt-get install -y libfile-fcntllock-perl
2022-01-20 12:48:22  142 [48530] (DEBUG):     Reading package lists...
2022-01-20 12:48:22  142 [48530] (DEBUG):     Building dependency tree...
2022-01-20 12:48:22  142 [48530] (DEBUG):     Reading state information...
2022-01-20 12:48:22  142 [48530] (DEBUG):     libfile-fcntllock-perl is already the newest version (0.22-3build4).
2022-01-20 12:48:22  142 [48530] (DEBUG):     You might want to run 'apt --fix-broken install' to correct these.
2022-01-20 12:48:22  142 [48530] (DEBUG):     The following packages have unmet dependencies:
2022-01-20 12:48:22  142 [48530] (DEBUG):      default-mysql-client : Depends: mysql-client-8.0 but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):      libmailutils6 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):      libsnmp35 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):      postfix-mysql : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):                      Depends: postfix (= 3.4.13-0ubuntu1.2) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):     E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
2022-01-20 12:48:22  142 [48530] (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/apt-get' exited with 100
2022-01-20 12:48:22  142 [48530] (DEBUG):   - ssystem [END]
2022-01-20 12:48:22  142 [48530] (DEBUG):   - ssystem [BEGIN]: /usr/bin/apt-get install -y libfile-fcntllock-perl
2022-01-20 12:48:22  142 [48530] (DEBUG):     Reading package lists...
2022-01-20 12:48:22  142 [48530] (DEBUG):     Building dependency tree...
2022-01-20 12:48:22  142 [48530] (DEBUG):     Reading state information...
2022-01-20 12:48:22  142 [48530] (DEBUG):     libfile-fcntllock-perl is already the newest version (0.22-3build4).
2022-01-20 12:48:22  142 [48530] (DEBUG):     You might want to run 'apt --fix-broken install' to correct these.
2022-01-20 12:48:22  142 [48530] (DEBUG):     The following packages have unmet dependencies:
2022-01-20 12:48:22  142 [48530] (DEBUG):      default-mysql-client : Depends: mysql-client-8.0 but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):      libmailutils6 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):      libsnmp35 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):      postfix-mysql : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):                      Depends: postfix (= 3.4.13-0ubuntu1.2) but it is not going to be installed
2022-01-20 12:48:22  142 [48530] (DEBUG):     E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
2022-01-20 12:48:22  142 [48530] (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/apt-get' exited with 100
2022-01-20 12:48:22  142 [48530] (DEBUG):   - ssystem [END]
2022-01-20 12:48:22  142 [48530] (DEBUG):   - ssystem [BEGIN]: /usr/bin/apt-get install -y libfile-fcntllock-perl
2022-01-20 12:48:22  142 [48530] (DEBUG):     Reading package lists...
2022-01-20 12:48:23  142 [48530] (DEBUG):     Building dependency tree...
2022-01-20 12:48:23  142 [48530] (DEBUG):     Reading state information...
2022-01-20 12:48:23  142 [48530] (DEBUG):     libfile-fcntllock-perl is already the newest version (0.22-3build4).
2022-01-20 12:48:23  142 [48530] (DEBUG):     You might want to run 'apt --fix-broken install' to correct these.
2022-01-20 12:48:23  142 [48530] (DEBUG):     The following packages have unmet dependencies:
2022-01-20 12:48:23  142 [48530] (DEBUG):      default-mysql-client : Depends: mysql-client-8.0 but it is not going to be installed
2022-01-20 12:48:23  142 [48530] (DEBUG):      libmailutils6 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:23  142 [48530] (DEBUG):      libsnmp35 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:23  142 [48530] (DEBUG):      postfix-mysql : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:23  142 [48530] (DEBUG):                      Depends: postfix (= 3.4.13-0ubuntu1.2) but it is not going to be installed
2022-01-20 12:48:23  142 [48530] (DEBUG):     E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
2022-01-20 12:48:23  142 [48530] (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/apt-get' exited with 100
2022-01-20 12:48:23  142 [48530] (DEBUG):   - ssystem [END]
2022-01-20 12:48:23  142 [48530] (DEBUG):   - ssystem [BEGIN]: /usr/bin/apt-get install -y libfile-fcntllock-perl
2022-01-20 12:48:23  142 [48530] (DEBUG):     Reading package lists...
2022-01-20 12:48:23  142 [48530] (DEBUG):     Building dependency tree...
2022-01-20 12:48:23  142 [48530] (DEBUG):     Reading state information...
2022-01-20 12:48:23  142 [48530] (DEBUG):     libfile-fcntllock-perl is already the newest version (0.22-3build4).
2022-01-20 12:48:23  142 [48530] (DEBUG):     You might want to run 'apt --fix-broken install' to correct these.
2022-01-20 12:48:23  142 [48530] (DEBUG):     The following packages have unmet dependencies:
2022-01-20 12:48:23  142 [48530] (DEBUG):      default-mysql-client : Depends: mysql-client-8.0 but it is not going to be installed
2022-01-20 12:48:23  142 [48530] (DEBUG):      libmailutils6 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:23  142 [48530] (DEBUG):      libsnmp35 : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:23  142 [48530] (DEBUG):      postfix-mysql : Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
2022-01-20 12:48:23  142 [48530] (DEBUG):                      Depends: postfix (= 3.4.13-0ubuntu1.2) but it is not going to be installed
2022-01-20 12:48:23  142 [48530] (DEBUG):     E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
2022-01-20 12:48:23  142 [48530] (ERROR):   - ssystem [EXIT_CODE] '/usr/bin/apt-get' exited with 100
2022-01-20 12:48:23  142 [48530] (DEBUG):   - ssystem [END]
2022-01-20 12:48:23   44 [48530] ( INFO): cPanel is here to help! Our Technical Support team is just a click away at https://support.cpanel.net/ or you can contact Customer Service via email [email protected]
2022-01-20 12:48:23  146 [48530] (FATAL): apt failed 6 times. The installation process cannot continue.