Unable to install on Amazon Linux

zoomphoto

Registered
Jul 2, 2011
1
0
51
Trying to install Cpanel on Amazon Linux. I've installed it many times on Centos over the years, never a problem.

[2015-12-04 18:11:57 +0000] ***** FATAL: Error testing if the RPMs will install: Test install failed: error: Failed dependencies:

[2015-12-04 18:11:57 +0000] liblzma.so.0()(64bit) is needed by dovecot-1:2.2.19-1.cp1148.x86_64

Any ideas?
 

cPBrett

cPanel Developer
Staff member
Jul 2, 2014
10
1
78
cPanel Access Level
Root Administrator
Direct installations of cPanel are not supported, but we have an initial AMI that we created some months ago, "Official cPanel CURRENT (11.52.0.13) - Amazon Linux (2015.09)" - AMI id is "ami-61e3b704".

You can install this AMI to jump start it, it will put you at 11.52.0.13.

Before running upcp to update the version of cPanel to the latest RELEASE, I recommend ensuring that "xz-compat-libs-5.1.2-8alpha.11.amzn1.x86_6" is installed via yum as suggested above.

We are in the process of getting an updated AMI of a recent RELEASE (11.52.2.2) into the Amazon AWS Marketplace. This AMI will have xz-compat-libs-5.1.2-8alpha.11.amzn1.x86_6 already installed. Moving forward, this will become the recommended means of creating Amazon Linux instances running cPanel.

Thank you,
Brett
 

Matteo Hertel

Registered
Apr 18, 2016
1
0
1
London
cPanel Access Level
Root Administrator
Direct installations of cPanel are not supported, but we have an initial AMI that we created some months ago, "Official cPanel CURRENT (11.52.0.13) - Amazon Linux (2015.09)" - AMI id is "ami-61e3b704".

You can install this AMI to jump start it, it will put you at 11.52.0.13.

Before running upcp to update the version of cPanel to the latest RELEASE, I recommend ensuring that "xz-compat-libs-5.1.2-8alpha.11.amzn1.x86_6" is installed via yum as suggested above.

We are in the process of getting an updated AMI of a recent RELEASE (11.52.2.2) into the Amazon AWS Marketplace. This AMI will have xz-compat-libs-5.1.2-8alpha.11.amzn1.x86_6 already installed. Moving forward, this will become the recommended means of creating Amazon Linux instances running cPanel.

Thank you,
Brett
The image is working fine however when I try to update to the last version I'm getting the same error as when I try to install WHM into a brand new ec2 instance

***** FATAL: Test install failed: error: Failed dependencies:
liblzma.so.0()(64bit) is needed by dovecot-1:2.2.19-1.cp1148.x86_64
The Administrator will be notified to review this output when this script completes
***** FATAL: Error testing if the RPMs will install: Test install failed: error: Failed dependencies:
liblzma.so.0()(64bit) is needed by dovecot-1:2.2.19-1.cp1148.x86_64
see RPM Installation Failures - cPanel Knowledge Base - cPanel Documentation for more information

I also tried to run the command
Code:
yum install xz-compat-libs-5.1.2-8alpha.11.amzn1.x86_64
but I'm getting an error
Code:
sudo yum install xz-compat-libs-5.1.2-8alpha.11.amzn1.x86_6
Loaded plugins: priorities, update-motd, upgrade-helper
No package xz-compat-libs-5.1.2-8alpha.11.amzn1.x86_6 available.
Error: Nothing to do
Any idea on how to fix this?

Cheers
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
No package xz-compat-libs-5.1.2-8alpha.11.amzn1.x86_6 available.
Hello :)

You can try installing the package with the following command to ensure it utilizes the most recent version:

Code:
yum install xz-compat-libs
Thank you.