Unable to install Pear package HTTP_Request2

Benji-44

Registered
Sep 14, 2020
1
0
1
New Zealand
cPanel Access Level
Website Owner
Hello all,

I don't know if this is in the correct thread but here it goes anyway. I need the http_request2 module to run some of my php code, however i cant seem to install it in cpanel. Here is the error I get...

WARNING: "pear/Console_Getopt" is deprecated in favor of "pear/Console_GetoptPlus"
pear/PEAR requires package "pear/Archive_Tar" (recommended version 1.4.4), installed version is 1.4.4
pear/HTTP_Request2 requires package "pear/PEAR" (version >= 1.9.2)
No valid packages found
install failed

Any ideas?

Cheers,
Ben
 

andrew.n

Well-Known Member
Jun 9, 2020
310
65
28
EU
cPanel Access Level
Root Administrator
Ben, look at the error message :)

pear/HTTP_Request2 requires package "pear/PEAR" (version >= 1.9.2)

upgrade the currently install pear version to 1.9.2 and it will work
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,251
313
Houston
I'm curious, why you have that version installed, right now the default PEAR version is 1.10.7 which is what I've got for all PHP versions on my server, he's the info for PHP 7.4

Code:
Installed Packages
Name        : ea-php74-pear
Arch        : noarch
Version     : 1.10.7
Release     : 4.4.6.cpanel
Size        : 2.1 M
Repo        : installed
From repo   : EA4
Summary     : PHP Extension and Application Repository framework
URL         : http://pear.php.net/package/PEAR
License     : BSD and PHP and LGPLv2+
Description : PEAR/PECL is a framework and distribution system for reusable PHP
            : components.  This package contains the basic PEAR components.