Unable to install R1soft module for latest cloudlinux kernel

Operating System & Version
CloudLinux release 8.5
cPanel & WHM Version
v100.0.5

garconcn

Well-Known Member
Oct 29, 2009
172
18
68
I just installed CloudLinux release 8.5 with cpanel, but unable to install the r1soft hcpdriver module. Anyone else have this issue? unable to reach R1soft support or find any info from their site.


My current kernel version:


# uname -a
Linux 4.18.0-348.lve.el8.x86_64 #1 SMP Sun Nov 21 10:56:33 EST 2021 x86_64 x86_64 x86_64 GNU/Linux


# r1soft-setup --get-module

Failed to get suitable module for this system: Failed to build module: No builders found.
 

ffeingol

Well-Known Member
PartnerNOC
Nov 9, 2001
765
310
363
cPanel Access Level
DataCenter Provider
You'd prob. need to contact R1Soft support for that. Sounds like they don't have a pre-built module for that kernel and they build system is having issues.
 

andrew.n

Well-Known Member
Jun 9, 2020
930
345
63
EU
cPanel Access Level
Root Administrator
I don't have a module for this :( you need to reach out to your license provider which can get in touch with r1 to build one for you manually.
 

amanfredini

Member
Aug 12, 2017
11
0
1
Italia
cPanel Access Level
Root Administrator
I don't have a module for this :( you need to reach out to your license provider which can get in touch with r1 to build one for you manually.
In the previous reply, "I just asked them to build it for you, here you are:"

Can you contact them for build them? They doesn't reply to my email since 5 days. I've 2 CDP licenses too. Can you try?
 

andrew.n

Well-Known Member
Jun 9, 2020
930
345
63
EU
cPanel Access Level
Root Administrator
provide the followings please:

r1soft-setup --get-module
uname -a
uname -r
cat /etc/redhat-release
 

amanfredini

Member
Aug 12, 2017
11
0
1
Italia
cPanel Access Level
Root Administrator
provide the followings please:

r1soft-setup --get-module
uname -a
uname -r
cat /etc/redhat-release
r1soft-setup --get-module
Building header archive ...
outfile = /tmp/headers543853838
headers = /usr/src/linux-headers-5.10.0-11-amd64
Session ID: 632473373
Waiting to upload...
Uploading file...
Waiting in build queue...
Failed to get suitable module for this system: Failed to build module: No builders found.

Get module failed.
Falling back to old get-module ...
signal: segmentation fault


uname -a
Linux 5.10.0-11-amd64 #1 SMP Debian 5.10.92-1 (2022-01-18) x86_64 GNU/Linux

uname -r
5.10.0-11-amd64

cat /etc/*release*
ID="generic"
VERSION="20220121-894"
PRETTY_NAME="Debian GNU/Linux 11 (bullseye)"
NAME="Debian GNU/Linux"
VERSION_ID="11"
VERSION="11 (bullseye)"
VERSION_CODENAME=bullseye
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"
 

andrew.n

Well-Known Member
Jun 9, 2020
930
345
63
EU
cPanel Access Level
Root Administrator
can you check the version for me too pls?

dpkg -l | grep serverbackup
 

amanfredini

Member
Aug 12, 2017
11
0
1
Italia
cPanel Access Level
Root Administrator
can you check the version for me too pls?

dpkg -l | grep serverbackup
ii serverbackup-agent 6.16.1-51 amd64 R1soft Server Backup Agent
ii serverbackup-async-agent-2-6 6.16.1-51 amd64 R1soft Server Backup Asynchronous Agent
ii serverbackup-enterprise-agent 6.16.1-51 amd64 R1soft Server Backup Enterprise Agent
ii serverbackup-setup 6.16.1-51 amd64 R1soft Server Backup Server and Agent Setup
 

andrew.n

Well-Known Member
Jun 9, 2020
930
345
63
EU
cPanel Access Level
Root Administrator
Yeah it will take a bit...I need more info:

cat /proc/version

and generate this tarball please and upload it somewhere or attach here:

serverbackup-setup --get-module --tarball-only /tmp/kernel-tarball.tar.gz
 

amanfredini

Member
Aug 12, 2017
11
0
1
Italia
cPanel Access Level
Root Administrator
Yeah it will take a bit...I need more info:

cat /proc/version

and generate this tarball please and upload it somewhere or attach here:

serverbackup-setup --get-module --tarball-only /tmp/kernel-tarball.tar.gz
here tarball : headers975775585.tar.gz

cat /proc/version
Linux version 5.10.0-11-amd64 ([email protected]) (gcc-10 (Debian 10.2.1-6) 10.2.1 20210110, GNU ld (GNU Binutils for Debian) 2.35.2) #1 SMP Debian 5.10.92-1 (2022-01-18)
 

andrew.n

Well-Known Member
Jun 9, 2020
930
345
63
EU
cPanel Access Level
Root Administrator
so I was told it's still in beta, they will build a custom module for it but first it needs to be released as stable. Based on this I can imagine it will take a longer time...I would say even weeks but will let you know once I heard back from them.
 
  • Like
Reactions: amanfredini