The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to load dynamic library

Discussion in 'General Discussion' started by Ariful Haque, Oct 18, 2016.

Tags:
  1. Ariful Haque

    Ariful Haque Registered

    Joined:
    Oct 18, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bangladesh
    cPanel Access Level:
    Root Administrator
    I'm getting
    Code:
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/pdo_mysql.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20131226/pdo_mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
    
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/pdo_mysql.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20131226/pdo_mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
    
    these error.

    I have run grep extension /usr/local/lib/php.ini from ssh as root and the output is as follow:

    Code:
    
    ; dynamically loaded extension (either a PHP extension or a Zend extension),
    ; you may only use these constants *after* the line that loads the extension.
    ; leading '/'. You must also specify the file extension being used including
    ; Directory in which the loadable extensions (modules) reside.
    extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20131226"
    zend_extension = "/usr/local/IonCube/ioncube_loader_lin_5.6.so"
    ; If you wish to have an extension loaded automatically, use the following
    extension = "pdo_sqlite.so"
    extension = "pdo.so"
    extension = "imagick.so"
    extension = "pdo_mysql.so"
    ; needs to go here. Specify the location of the extension with the
    ; extension_dir directive above.
    ; dictionary files. Include the base filename, but not the file extension.
    
    
    please help me solve the issue.
     
    #1 Ariful Haque, Oct 18, 2016
    Last edited by a moderator: Oct 18, 2016
  2. cPanelJimmy

    cPanelJimmy Technical Analyst Supervisor
    Staff Member

    Joined:
    Jun 11, 2014
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    Hello,

    This issue is likely due to the pdo_mysql.so module missing from the
    /usr/local/lib/php/extensions/no-debug-non-zts-20131226/ directory. If you run an 'ls' on that directory is the file showing in there? Do you need the PDO MySQL extension? If so, I recommend re-running the EasyApache tool and selecting the PDO option under the PHP section. If you don't need it, you should be able to remove the:

    Code:
    extension = "pdo_mysql.so"
    entry from the php.ini file and then restart your Apache web service.

    If you're still having any issues I recommend reaching out to our support team via a ticket so we can take a further look!

    Thanks,
     
Loading...

Share This Page